diff mbox series

[7/7] kernel/kernel-devsrc: powerpc: add elfutils dependency

Message ID 4a324eced96a8cc5c37ace9c825addd25b2a92e2.1679670268.git.bruce.ashfield@gmail.com
State Accepted, archived
Commit 14b815b0beb6edc14b4fcc016201ade967875e28
Headers show
Series [1/7] linux-yocto/6.1: update to v6.1.15 | expand

Commit Message

Bruce Ashfield March 24, 2023, 3:08 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

When working on 6.3+ kernel support powerpc started to fail when
doing on target kerne module builds, and in some cases when building
the kernel itself.

This was due to crtsavres requiring objtool to build, which was
missing required development headers.

So in a similar manner to x86, we add elfutils as an arch specific
dependency in these recipes.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/linux/kernel-devsrc.bb   | 2 ++
 meta/recipes-kernel/linux/linux-yocto-dev.bb | 1 +
 2 files changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 6821efd38d..0e92182f6d 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -382,6 +382,8 @@  RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
 RDEPENDS:${PN} += "openssl-dev util-linux"
 # and x86 needs a bit more for 4.15+
 RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-dev', '', d)}"
+# powerpc needs elfutils on 6.3+
+RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'powerpc', 'elfutils-dev', '', d)}"
 # 5.8+ needs gcc-plugins libmpc-dev
 RDEPENDS:${PN} += "gcc-plugins libmpc-dev"
 # 5.13+ needs awk for arm64
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 4f3d4a5c3c..52cd6f5f28 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -35,6 +35,7 @@  PV = "${LINUX_VERSION}+git${SRCPV}"
 LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 
 DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "${@bb.utils.contains('ARCH', 'powerpc', 'elfutils-native', '', d)}"
 DEPENDS += "openssl-native util-linux-native"
 DEPENDS += "gmp-native libmpc-native"