diff mbox series

[10/17] python3-markupsafe: use python3-unittest-automake-output

Message ID 20230320132751.518693-10-ross.burton@arm.com
State Accepted, archived
Commit 721b5a81b176dd0f2aafb2fe3587d28df383eb7b
Headers show
Series [01/17] python3-numpy: add missing dependency for the tests | expand

Commit Message

Ross Burton March 20, 2023, 1:27 p.m. UTC
Instead of using sed to reformat the output use this new module.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-markupsafe/run-ptest | 2 +-
 meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb  | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Richard Purdie March 20, 2023, 5:06 p.m. UTC | #1
On Mon, 2023-03-20 at 13:27 +0000, Ross Burton wrote:
> Instead of using sed to reformat the output use this new module.
> 
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-devtools/python/python3-markupsafe/run-ptest | 2 +-
>  meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb  | 4 ++--
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/meta/recipes-devtools/python/python3-markupsafe/run-ptest b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
> index 5cec7116968..8d2017d39ce 100644
> --- a/meta/recipes-devtools/python/python3-markupsafe/run-ptest
> +++ b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
> @@ -1,3 +1,3 @@
>  #!/bin/sh
>  
> -pytest
> +pytest --automake
> diff --git a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
> index f4f0ad2df0f..32420529635 100644
> --- a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
> +++ b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
> @@ -6,8 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
>  SRC_URI[sha256sum] = "abcabc8c2b26036d62d4c746381a6f7cf60aafcc653198ad678306986b09450d"
>  
>  PYPI_PACKAGE = "MarkupSafe"
> -inherit pypi setuptools3
> -inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
> +inherit pypi setuptools3 ptest
>  
>  RDEPENDS:${PN} += "${PYTHON_PN}-stringold"
>  
> @@ -19,6 +18,7 @@ SRC_URI += " \
>  
>  RDEPENDS:${PN}-ptest += " \
>  	${PYTHON_PN}-pytest \
> +	${PYTHON_PN}-unittest-automake-output \
>  "
>  
>  do_install_ptest() {

Where is sed being used to reformat the output? I'm mainly proving I
did read the patches :)

Thanks for putting this series together, it does clean up all those
horrible sed expressions which is great to see.

Cheers,

Richard
Ross Burton March 20, 2023, 5:07 p.m. UTC | #2
On 20 Mar 2023, at 17:06, Richard Purdie <richard.purdie@linuxfoundation.org> wrote:
> 
> On Mon, 2023-03-20 at 13:27 +0000, Ross Burton wrote:
>> Instead of using sed to reformat the output use this new module.
>> 
>> Signed-off-by: Ross Burton <ross.burton@arm.com>
>> ---
>> meta/recipes-devtools/python/python3-markupsafe/run-ptest | 2 +-
>> meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb  | 4 ++--
>> 2 files changed, 3 insertions(+), 3 deletions(-)
>> 
>> diff --git a/meta/recipes-devtools/python/python3-markupsafe/run-ptest b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
>> index 5cec7116968..8d2017d39ce 100644
>> --- a/meta/recipes-devtools/python/python3-markupsafe/run-ptest
>> +++ b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
>> @@ -1,3 +1,3 @@
>> #!/bin/sh
>> 
>> -pytest
>> +pytest --automake
>> diff --git a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
>> index f4f0ad2df0f..32420529635 100644
>> --- a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
>> +++ b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
>> @@ -6,8 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
>> SRC_URI[sha256sum] = "abcabc8c2b26036d62d4c746381a6f7cf60aafcc653198ad678306986b09450d"
>> 
>> PYPI_PACKAGE = "MarkupSafe"
>> -inherit pypi setuptools3
>> -inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
>> +inherit pypi setuptools3 ptest
>> 
>> RDEPENDS:${PN} += "${PYTHON_PN}-stringold"
>> 
>> @@ -19,6 +18,7 @@ SRC_URI += " \
>> 
>> RDEPENDS:${PN}-ptest += " \
>> ${PYTHON_PN}-pytest \
>> + ${PYTHON_PN}-unittest-automake-output \
>> "
>> 
>> do_install_ptest() {
> 
> Where is sed being used to reformat the output? I'm mainly proving I
> did read the patches :)

You got me: this one didn’t even do the sed dance but I was copy/pasting the commit message. :)

Ross
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-markupsafe/run-ptest b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
index 5cec7116968..8d2017d39ce 100644
--- a/meta/recipes-devtools/python/python3-markupsafe/run-ptest
+++ b/meta/recipes-devtools/python/python3-markupsafe/run-ptest
@@ -1,3 +1,3 @@ 
 #!/bin/sh
 
-pytest
+pytest --automake
diff --git a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
index f4f0ad2df0f..32420529635 100644
--- a/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
+++ b/meta/recipes-devtools/python/python3-markupsafe_2.1.2.bb
@@ -6,8 +6,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
 SRC_URI[sha256sum] = "abcabc8c2b26036d62d4c746381a6f7cf60aafcc653198ad678306986b09450d"
 
 PYPI_PACKAGE = "MarkupSafe"
-inherit pypi setuptools3
-inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
+inherit pypi setuptools3 ptest
 
 RDEPENDS:${PN} += "${PYTHON_PN}-stringold"
 
@@ -19,6 +18,7 @@  SRC_URI += " \
 
 RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
+	${PYTHON_PN}-unittest-automake-output \
 "
 
 do_install_ptest() {