[meta-oe] cmatrix: new package

Message ID 20220106104532.204464-1-brgl@bgdev.pl
State New
Headers show
Series [meta-oe] cmatrix: new package | expand

Commit Message

Bartosz Golaszewski Jan. 6, 2022, 10:45 a.m. UTC
This adds the recipe for cmatrix: a tool for displaying The Matrix like
codes in terminal.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
 meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb

Comments

Khem Raj Jan. 7, 2022, 7:11 p.m. UTC | #1
this fails to package on yocto AB

ERROR: cmatrix-2.0-r0 do_package: QA Issue: cmatrix: Files/directories
were installed but not shipped in any package:
  /usr/lib
  /usr/lib/kbd
  /usr/lib/kbd/consolefonts
  /usr/lib/kbd/consolefonts/matrix.psf.gz
  /usr/lib/kbd/consolefonts/matrix.fnt
Please set FILES such that these items are packaged. Alternatively if
they are unneeded, avoid installing them or delete them within
do_install.
cmatrix: 5 installed and not shipped files. [installed-vs-shipped]


for details see
https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/1816

On Thu, Jan 6, 2022 at 2:45 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:
>
> This adds the recipe for cmatrix: a tool for displaying The Matrix like
> codes in terminal.
>
> Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
> ---
>  meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb
>
> diff --git a/meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb b/meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb
> new file mode 100644
> index 000000000..3edf8ea90
> --- /dev/null
> +++ b/meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb
> @@ -0,0 +1,15 @@
> +SUMMARY = "Terminal based 'The Matrix' screen implementation"
> +AUTHOR = "Abishek V Ashok"
> +
> +LICENSE = "GPL-3.0"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
> +
> +SRC_URI = "git://github.com/abishekvashok/cmatrix.git;branch=stable;protocol=https"
> +SRCREV = "adfdf1656f23e5ab3b52c7d7edf91249a4477e8d"
> +S = "${WORKDIR}/git"
> +
> +inherit cmake
> +
> +DEPENDS += "ncurses"
> +
> +FILES:${PN} += "${datadir}/*"
> --
> 2.25.1
>

Patch

diff --git a/meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb b/meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb
new file mode 100644
index 000000000..3edf8ea90
--- /dev/null
+++ b/meta-oe/recipes-extended/cmatrix/cmatrix_2.0.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Terminal based 'The Matrix' screen implementation"
+AUTHOR = "Abishek V Ashok"
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "git://github.com/abishekvashok/cmatrix.git;branch=stable;protocol=https"
+SRCREV = "adfdf1656f23e5ab3b52c7d7edf91249a4477e8d"
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+DEPENDS += "ncurses"
+
+FILES:${PN} += "${datadir}/*"