diff mbox series

[02/16] openssl: Add missing ptest dependency on openssl-bin

Message ID 20230311002722.3211118-2-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit c29276b467ae10027f38cb403a2089b3558fc639
Headers show
Series [01/16] m4/opkg/ethtool/attr/libgpg-error: Add missing bash ptest dependency | expand

Commit Message

Richard Purdie March 11, 2023, 12:27 a.m. UTC
One of the openssl ptests needs the openssl binary so fails
on a minimal image without this. Add the missing dependency.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-connectivity/openssh/openssh_9.2p1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/openssh/openssh_9.2p1.bb b/meta/recipes-connectivity/openssh/openssh_9.2p1.bb
index e6cf2ff2d6b..4666237d686 100644
--- a/meta/recipes-connectivity/openssh/openssh_9.2p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_9.2p1.bb
@@ -158,7 +158,7 @@  FILES:${PN}-keygen = "${bindir}/ssh-keygen"
 RDEPENDS:${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen ${PN}-sftp-server"
 RDEPENDS:${PN}-sshd += "${PN}-keygen ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}"
 # gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies
-RDEPENDS:${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed sudo coreutils"
+RDEPENDS:${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed sudo coreutils openssl-bin"
 
 RPROVIDES:${PN}-ssh = "ssh"
 RPROVIDES:${PN}-sshd = "sshd"