Patchwork [v6,3/3] libzypp: add missing runtime dependences on gzip and gnupg

login
register
mail settings
Submitter Steve Sakoman
Date Feb. 1, 2012, 3:20 p.m.
Message ID <1328109632-3300-4-git-send-email-steve@sakoman.com>
Download mbox | patch
Permalink /patch/20497/
State New
Headers show

Comments

Steve Sakoman - Feb. 1, 2012, 3:20 p.m.
gzip is required to uncompress repository files
gnupg is required for the support of signed repositories.

Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-extended/libzypp/libzypp_git.bb |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index f494f1b..368cc06 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -11,7 +11,7 @@  DEPENDS  = "rpm boost curl libxml2 zlib sat-solver expat openssl udev"
 S = "${WORKDIR}/git"
 SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
 PV = "0.0-git${SRCPV}"
-PR = "r17"
+PR = "r18"
 
 SRC_URI = "git://github.com/openSUSE/libzypp.git;protocol=git \
            file://no-doc.patch \
@@ -30,7 +30,7 @@  SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"
 SRC_URI_append_arm  = " file://arm-workaround-global-constructor.patch"
 
 # rpmdb2solv from sat-solver is run from libzypp
-RDEPENDS_${PN} = "sat-solver rpm-libs"
+RDEPENDS_${PN} = "sat-solver rpm-libs gzip gnupg"
 
 PACKAGES =+ "${PN}-pkgmgt"