diff mbox series

linux: inherit pkgconfig in kernel.bbclass

Message ID 20230304163029.31124-1-liu.ming50@gmail.com
State Accepted, archived
Commit 8a84bd98e3fbc16c782f83064801e469d086911e
Headers show
Series linux: inherit pkgconfig in kernel.bbclass | expand

Commit Message

Ming Liu March 4, 2023, 4:30 p.m. UTC
From: Ming Liu <liu.ming50@gmail.com>

pkgconfig is being required to find dependencies for building kernel
native tools, move "inherit pkgconfig" to kernel.bbclass so BSP kernel
recipes can also benefit from it.

Signed-off-by: Ming Liu <liu.ming50@gmail.com>
---
 meta/classes-recipe/kernel.bbclass           | 2 +-
 meta/recipes-kernel/linux/linux-yocto-dev.bb | 2 --
 meta/recipes-kernel/linux/linux-yocto.inc    | 1 -
 3 files changed, 1 insertion(+), 4 deletions(-)

Comments

Bruce Ashfield March 6, 2023, 3:53 a.m. UTC | #1
On Sat, Mar 4, 2023 at 11:30 AM Ming Liu <liu.ming50@gmail.com> wrote:
>
> From: Ming Liu <liu.ming50@gmail.com>
>
> pkgconfig is being required to find dependencies for building kernel
> native tools, move "inherit pkgconfig" to kernel.bbclass so BSP kernel
> recipes can also benefit from it.

Reminder: copy me on linux-yocto changes!

This is fine with me. When I first introduced this, it wasn't
universally needed for all kernel versions, so it landed in
linux-yocto, where we knew the versions.

I'm betting that there are a lot of other kernel recipes with this
same inherit, and as long as they are all good with double inherits ..
nothing should break.

Bruce

>
> Signed-off-by: Ming Liu <liu.ming50@gmail.com>
> ---
>  meta/classes-recipe/kernel.bbclass           | 2 +-
>  meta/recipes-kernel/linux/linux-yocto-dev.bb | 2 --
>  meta/recipes-kernel/linux/linux-yocto.inc    | 1 -
>  3 files changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/meta/classes-recipe/kernel.bbclass b/meta/classes-recipe/kernel.bbclass
> index 3f9c6c00e6..92090ac14e 100644
> --- a/meta/classes-recipe/kernel.bbclass
> +++ b/meta/classes-recipe/kernel.bbclass
> @@ -660,7 +660,7 @@ do_savedefconfig() {
>  do_savedefconfig[nostamp] = "1"
>  addtask savedefconfig after do_configure
>
> -inherit cml1
> +inherit cml1 pkgconfig
>
>  # Need LD, HOSTLDFLAGS and more for config operations
>  KCONFIG_CONFIG_COMMAND:append = " ${EXTRA_OEMAKE}"
> diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
> index 9ef5b80a37..8039a52324 100644
> --- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
> @@ -10,8 +10,6 @@
>
>  inherit kernel
>  require recipes-kernel/linux/linux-yocto.inc
> -# for ncurses tests
> -inherit pkgconfig
>
>  # provide this .inc to set specific revisions
>  include recipes-kernel/linux/linux-yocto-dev-revisions.inc
> diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
> index 93eef9e946..934591ff1c 100644
> --- a/meta/recipes-kernel/linux/linux-yocto.inc
> +++ b/meta/recipes-kernel/linux/linux-yocto.inc
> @@ -47,7 +47,6 @@ LINUX_VERSION_EXTENSION ??= "-yocto-${LINUX_KERNEL_TYPE}"
>  # Pick up shared functions
>  inherit kernel
>  inherit kernel-yocto
> -inherit pkgconfig
>
>  B = "${WORKDIR}/linux-${PACKAGE_ARCH}-${LINUX_KERNEL_TYPE}-build"
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#178027): https://lists.openembedded.org/g/openembedded-core/message/178027
> Mute This Topic: https://lists.openembedded.org/mt/97386391/1050810
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/classes-recipe/kernel.bbclass b/meta/classes-recipe/kernel.bbclass
index 3f9c6c00e6..92090ac14e 100644
--- a/meta/classes-recipe/kernel.bbclass
+++ b/meta/classes-recipe/kernel.bbclass
@@ -660,7 +660,7 @@  do_savedefconfig() {
 do_savedefconfig[nostamp] = "1"
 addtask savedefconfig after do_configure
 
-inherit cml1
+inherit cml1 pkgconfig
 
 # Need LD, HOSTLDFLAGS and more for config operations
 KCONFIG_CONFIG_COMMAND:append = " ${EXTRA_OEMAKE}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 9ef5b80a37..8039a52324 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -10,8 +10,6 @@ 
 
 inherit kernel
 require recipes-kernel/linux/linux-yocto.inc
-# for ncurses tests
-inherit pkgconfig
 
 # provide this .inc to set specific revisions
 include recipes-kernel/linux/linux-yocto-dev-revisions.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 93eef9e946..934591ff1c 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -47,7 +47,6 @@  LINUX_VERSION_EXTENSION ??= "-yocto-${LINUX_KERNEL_TYPE}"
 # Pick up shared functions
 inherit kernel
 inherit kernel-yocto
-inherit pkgconfig
 
 B = "${WORKDIR}/linux-${PACKAGE_ARCH}-${LINUX_KERNEL_TYPE}-build"