diff mbox series

[meta-python] python3-fastnumbers: upgrade 4.0.1 -> 5.0.1

Message ID 1677927919-22891-5-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-fastnumbers: upgrade 4.0.1 -> 5.0.1 | expand

Commit Message

Mingyu Wang (Fujitsu) March 4, 2023, 11:05 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
Added
--------
    Added the map option to all try_* functions to enable very fast conversions of lists or other iterables (issues #61, #63 and #67)
    Added try_array to enable very fast conversions directly to numpy arrays (issues #62 and #65)

Changed
---------
    Move to a model where the return code is a value or error instead of a model where one has to check the error state after getting a value (issue #66)
    Significantly simplified the type annotations (by 4000+ lines!)

Fixed
-------
    Increased code coverage and fixed missing headers in codecov reaport (issue #64)
    Add back missing key option in type hints for deprecated fast_* functions

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ython3-fastnumbers_4.0.1.bb => python3-fastnumbers_5.0.1.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-fastnumbers_4.0.1.bb => python3-fastnumbers_5.0.1.bb} (72%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-fastnumbers_4.0.1.bb b/meta-python/recipes-devtools/python/python3-fastnumbers_5.0.1.bb
similarity index 72%
rename from meta-python/recipes-devtools/python/python3-fastnumbers_4.0.1.bb
rename to meta-python/recipes-devtools/python/python3-fastnumbers_5.0.1.bb
index e3a0c6c0f..7494c45f0 100644
--- a/meta-python/recipes-devtools/python/python3-fastnumbers_4.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-fastnumbers_5.0.1.bb
@@ -5,6 +5,6 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=58db8ac9e152dd9b700f4d39ff40a31a"
 
 PYPI_PACKAGE = "fastnumbers"
 
-SRC_URI[sha256sum] = "3e7d74b1debb44c4803c0fea59a63d0785d6a26ebcb902e2262b3c3fba81b400"
+SRC_URI[sha256sum] = "9e4fd92cdf263a8e0865af19c40ae9df45a9bc0eb5e22fefea871140e7e0262f"
 
 inherit pypi setuptools3