Patchwork [v4,3/3] zypper: add missing runtime dependences on gzip and gnupg

login
register
mail settings
Submitter Steve Sakoman
Date Jan. 30, 2012, 9:12 p.m.
Message ID <1327957970-15159-4-git-send-email-steve@sakoman.com>
Download mbox | patch
Permalink /patch/20355/
State New
Headers show

Comments

Steve Sakoman - Jan. 30, 2012, 9:12 p.m.
gzip is required to uncompress repository files
gnupg is required for the support of signed repositories.

Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-extended/zypper/zypper_git.bb |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-extended/zypper/zypper_git.bb b/meta/recipes-extended/zypper/zypper_git.bb
index e5963be..bb456fe 100644
--- a/meta/recipes-extended/zypper/zypper_git.bb
+++ b/meta/recipes-extended/zypper/zypper_git.bb
@@ -5,7 +5,7 @@  LICENSE  = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=3201406e350b39e05a82e28b5020f413"
 
 DEPENDS  = "libzypp augeas"
-PR = "r1"
+PR = "r2"
 SRCREV = "2c5bb6ceb99ecd950ef993e43d77bf0569ea0582"
 
 inherit cmake
@@ -20,7 +20,7 @@  S = "${WORKDIR}/git"
 
 PV = "1.5.3-git${SRCPV}"
 
-RDEPENDS_${PN} = "rpm-libs"
+RDEPENDS_${PN} = "rpm-libs gzip gnupg"
 RRECOMMENDS_${PN} = "procps util-linux-uuidgen"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"