diff mbox series

[meta-python,landgale] python3-pybind11: Upgrade to 2.10.3

Message ID 20230225195655.3682899-1-kekiefer@gmail.com
State New
Headers show
Series [meta-python,landgale] python3-pybind11: Upgrade to 2.10.3 | expand

Commit Message

Kurt Kiefer Feb. 25, 2023, 7:56 p.m. UTC
From: Khem Raj <raj.khem@gmail.com>

It gets pkgconfig support which is required by some dependent packages
like rwmem

Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit 5c455804aede17e0ea0cbb7ab55f8580f912e664)
Signed-off-by: Kurt Kiefer <kekiefer@gmail.com>
---
 ...11_2.10.0.bb => python3-pybind11_2.10.3.bb} | 18 +++++++-----------
 1 file changed, 7 insertions(+), 11 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pybind11_2.10.0.bb => python3-pybind11_2.10.3.bb} (68%)

Comments

Kurt Kiefer Feb. 27, 2023, 4:37 p.m. UTC | #1
> On Feb 25, 2023, at 11:56 AM, kekiefer@gmail.com wrote:
> 
> From: Khem Raj <raj.khem@gmail.com>
> 
> It gets pkgconfig support which is required by some dependent packages
> like rwmem
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> (cherry picked from commit 5c455804aede17e0ea0cbb7ab55f8580f912e664)
> Signed-off-by: Kurt Kiefer <kekiefer@gmail.com>


I would like to retract this submission. I'm going to resubmit a more surgical
patch to the existing version, and provide rationale for why a fix is needed
on langdale.

Thanks, and I apologize for the thrash,

Kurt
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
similarity index 68%
rename from meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
rename to meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
index 66aefac3d..bb604982d 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
@@ -5,16 +5,12 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
 
 DEPENDS = "boost"
 
-SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
-           file://0001-Do-not-strip-binaries.patch \
-"
+SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https"
 
-SRCREV = "aa304c9c7d725ffb9d10af08a3b34cb372307020"
+SRCREV = "0bd8896a4010f2d91b2340570c24fa08606ec406"
 
 S = "${WORKDIR}/git"
 
-BBCLASSEXTEND = "native"
-
 EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
 
 inherit cmake setuptools3 python3native
@@ -23,17 +19,17 @@  PIP_INSTALL_DIST_PATH = "${S}/dist"
 PIP_INSTALL_PACKAGE = "pybind11"
 
 do_configure() {
-	cmake_do_configure
+   cmake_do_configure
 }
 
 do_compile() {
-	setuptools3_do_compile
-	cmake_do_compile
+   setuptools3_do_compile
+   cmake_do_compile
 }
 
 do_install() {
-	setuptools3_do_install
-	cmake_do_install
+   setuptools3_do_install
+   cmake_do_install
 }
 
 BBCLASSEXTEND = "native nativesdk"