diff mbox series

[meta-oe] libvpx: Explicitly link with pthread support

Message ID 20230222165122.1489645-1-JPEWhacker@gmail.com
State Under Review
Headers show
Series [meta-oe] libvpx: Explicitly link with pthread support | expand

Commit Message

Joshua Watt Feb. 22, 2023, 4:51 p.m. UTC
Some platforms (e.g. x86) require that the build (host) tools be
explicitly linked with -pthread to link against the pthread libraries so
do that here.

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
---
 meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Khem Raj Feb. 22, 2023, 6:38 p.m. UTC | #1
On Wed, Feb 22, 2023 at 8:51 AM Joshua Watt <JPEWhacker@gmail.com> wrote:
>
> Some platforms (e.g. x86) require that the build (host) tools be
> explicitly linked with -pthread to link against the pthread libraries so
> do that here.
>

what is the underlying reason ? does it need some sort of cancellation support ?
maybe add build error snippet to commit to expand on it a bit.

> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
> ---
>  meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb
> index 066d7cc81..9c04c2a34 100644
> --- a/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb
> +++ b/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb
> @@ -19,6 +19,7 @@ S = "${WORKDIR}/git"
>  ARM_INSTRUCTION_SET = "arm"
>
>  CFLAGS += "-fPIC"
> +BUILD_LDFLAGS += "-pthread"
>
>  export CC
>  export LD = "${CC}"
> --
> 2.33.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#101217): https://lists.openembedded.org/g/openembedded-devel/message/101217
> Mute This Topic: https://lists.openembedded.org/mt/97163975/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb
index 066d7cc81..9c04c2a34 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.12.0.bb
@@ -19,6 +19,7 @@  S = "${WORKDIR}/git"
 ARM_INSTRUCTION_SET = "arm"
 
 CFLAGS += "-fPIC"
+BUILD_LDFLAGS += "-pthread"
 
 export CC
 export LD = "${CC}"