diff mbox series

[8/8] nodejs: no need to stage binaries for target

Message ID 20230220154614.42832-8-ross.burton@arm.com
State Under Review
Headers show
Series [1/8] zchunk: upgrade to 1.2.3 | expand

Commit Message

Ross Burton Feb. 20, 2023, 3:46 p.m. UTC
Target nodejs doesn't depend on nodejs-native to build anymore, so there
is no need to stage these binaries.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb | 13 -------------
 1 file changed, 13 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
index c95a72fa94..0346f54e6f 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
@@ -174,19 +174,6 @@  do_install_ptest () {
     chown -R root:root ${D}${PTEST_PATH}
 }
 
-BINARIES = " \
-    bytecode_builtins_list_generator \
-    ${@bb.utils.contains('PACKAGECONFIG', 'icu', 'gen-regexp-special-case', '', d)} \
-    node_mksnapshot \
-    torque \
-"
-
-do_install:append:class-native() {
-    # Install the native binaries to provide it within sysroot for the target compilation
-    install -d ${D}${bindir}
-    (cd ${S}/out/Release && install ${BINARIES} ${D}${bindir})
-}
-
 PACKAGES =+ "${PN}-npm"
 FILES:${PN}-npm = "${nonarch_libdir}/node_modules ${bindir}/npm ${bindir}/npx"
 RDEPENDS:${PN}-npm = "bash python3-core python3-shell python3-datetime \