diff mbox series

[meta-oe] jsonrpc: upgrade 1.3.0 -> 1.4.1

Message ID 1676702342-30766-2-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-oe] jsonrpc: upgrade 1.3.0 -> 1.4.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 18, 2023, 6:39 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-Fix-build-with-libmicrohttpd.patch
removed since it's included in 1.4.1

Changelog:
===========
- Fedora CI build by updating to Catch v2.13.7
- Typo in README (#313)
- Deprecation warnings for Jsoncpp (#312)
- Compatibility with newer libmicrohttpd versions (>= 0.9.71) (#298 #299)
- Typo in diagram (#293)
- File descriptor leaks in connectors

- Vendoring catch library instead of downloading from github
- Moved from travis-ci to circleci (#311)
- Use '.empty()' checks instead of '.size() == 0'

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../0001-Fix-build-with-libmicrohttpd.patch   | 52 -------------------
 .../{jsonrpc_1.3.0.bb => jsonrpc_1.4.1.bb}    |  6 +--
 2 files changed, 2 insertions(+), 56 deletions(-)
 delete mode 100644 meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-Fix-build-with-libmicrohttpd.patch
 rename meta-oe/recipes-devtools/jsonrpc/{jsonrpc_1.3.0.bb => jsonrpc_1.4.1.bb} (87%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-Fix-build-with-libmicrohttpd.patch b/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-Fix-build-with-libmicrohttpd.patch
deleted file mode 100644
index a4cacb3fc..000000000
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc/0001-Fix-build-with-libmicrohttpd.patch
+++ /dev/null
@@ -1,52 +0,0 @@ 
-From d983161415f5f5748fbdbaa5fbd168154ccf8867 Mon Sep 17 00:00:00 2001
-From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
-Date: Wed, 5 Aug 2020 12:31:24 +0900
-Subject: [PATCH] Fix build with libmicrohttpd 0.9.71
-
----
- src/jsonrpccpp/server/connectors/httpserver.cpp | 2 +-
- src/jsonrpccpp/server/connectors/httpserver.h   | 8 +++++++-
- 2 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/src/jsonrpccpp/server/connectors/httpserver.cpp b/src/jsonrpccpp/server/connectors/httpserver.cpp
-index a849615..dd3b841 100644
---- a/src/jsonrpccpp/server/connectors/httpserver.cpp
-+++ b/src/jsonrpccpp/server/connectors/httpserver.cpp
-@@ -151,7 +151,7 @@ void HttpServer::SetUrlHandler(const string &url,
-   this->SetHandler(NULL);
- }
- 
--int HttpServer::callback(void *cls, MHD_Connection *connection, const char *url,
-+mhd_result HttpServer::callback(void *cls, MHD_Connection *connection, const char *url,
-                          const char *method, const char *version,
-                          const char *upload_data, size_t *upload_data_size,
-                          void **con_cls) {
-diff --git a/src/jsonrpccpp/server/connectors/httpserver.h b/src/jsonrpccpp/server/connectors/httpserver.h
-index 7785edb..0dcf032 100644
---- a/src/jsonrpccpp/server/connectors/httpserver.h
-+++ b/src/jsonrpccpp/server/connectors/httpserver.h
-@@ -32,6 +32,12 @@ typedef intptr_t ssize_t;
- #include <map>
- #include <microhttpd.h>
- 
-+#if MHD_VERSION >= 0x00097002
-+#  define mhd_result enum MHD_Result
-+#else
-+#  define mhd_result int
-+#endif
-+
- namespace jsonrpc {
- /**
-  * This class provides an embedded HTTP Server, based on libmicrohttpd, to
-@@ -79,7 +85,7 @@ private:
-   std::map<std::string, IClientConnectionHandler *> urlhandler;
-   struct sockaddr_in loopback_addr;
- 
--  static int callback(void *cls, struct MHD_Connection *connection,
-+  static mhd_result callback(void *cls, struct MHD_Connection *connection,
-                       const char *url, const char *method, const char *version,
-                       const char *upload_data, size_t *upload_data_size,
-                       void **con_cls);
--- 
-2.25.1
-
diff --git a/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.3.0.bb b/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.4.1.bb
similarity index 87%
rename from meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.3.0.bb
rename to meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.4.1.bb
index 43dc2e36a..544922f05 100644
--- a/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.3.0.bb
+++ b/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.4.1.bb
@@ -9,11 +9,9 @@  SECTION = "libs"
 
 DEPENDS = "curl jsoncpp libmicrohttpd hiredis"
 
-SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp;branch=master;protocol=https \
-	   file://0001-Fix-build-with-libmicrohttpd.patch \
-"
+SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp;branch=master;protocol=https"
 
-SRCREV = "c696f6932113b81cd20cd4a34fdb1808e773f23e"
+SRCREV = "ec5ce12fc9c0299e1454cc002c70218b5a6f005b"
 
 S = "${WORKDIR}/git"