diff mbox series

[meta-oe,1/2] smemstat: add recipe

Message ID 20230214131349.1685229-1-jlu@pengutronix.de
State New
Headers show
Series [meta-oe,1/2] smemstat: add recipe | expand

Commit Message

Jan Lübbe Feb. 14, 2023, 1:13 p.m. UTC
This is useful to see which processes use physical memory.

Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
---
 .../smemstat/smemstat_0.02.11.bb              | 27 +++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb

Comments

Martin Jansa Feb. 14, 2023, 1:33 p.m. UTC | #1
FWIW: this was in meta-luneos for a while:
https://github.com/webOS-ports/meta-webos-ports/blob/master/meta-luneos/recipes-devtools/smemstat/smemstat_git.bb

since
https://github.com/webOS-ports/meta-webos-ports/commit/9c73ce110a6cd97a476c6beff10f9d8648cffea6

I didn't compare the output from your version, but does it set the VERSION
correctly now?

Regards,

On Tue, Feb 14, 2023 at 2:14 PM Jan Luebbe <jlu@pengutronix.de> wrote:

> This is useful to see which processes use physical memory.
>
> Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
> ---
>  .../smemstat/smemstat_0.02.11.bb              | 27 +++++++++++++++++++
>  1 file changed, 27 insertions(+)
>  create mode 100644 meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
>
> diff --git a/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
> b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
> new file mode 100644
> index 000000000000..37015ce6bdc1
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
> @@ -0,0 +1,27 @@
> +SUMMARY = "smemstat reports the physical memory usage taking into
> consideration shared memory"
> +HOMEPAGE = "https://github.com/ColinIanKing/smemstat"
> +LICENSE = "GPL-2.0-or-later"
> +
> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +
> +DEPENDS = "ncurses"
> +
> +SRC_URI = "git://
> github.com/ColinIanKing/smemstat.git;protocol=https;branch=master"
> +SRCREV = "9eea7504ab33783d804c4ed9237e299effb68874"
> +
> +S = "${WORKDIR}/git"
> +
> +do_configure () {
> +       :
> +}
> +
> +do_compile () {
> +       oe_runmake
> +}
> +
> +do_install () {
> +       install -d -m 755 ${D}${sbindir}
> +       install -m 755 ${B}/smemstat ${D}${sbindir}/
> +       install -d -m 755 ${D}${mandir}/man8
> +       install -m 644 ${S}/smemstat.8 ${D}${mandir}/man8/
> +}
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#101071):
> https://lists.openembedded.org/g/openembedded-devel/message/101071
> Mute This Topic: https://lists.openembedded.org/mt/96959306/3617156
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> Martin.Jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Jan Lübbe Feb. 14, 2023, 2:43 p.m. UTC | #2
On Tue, 2023-02-14 at 14:33 +0100, Martin Jansa wrote:
> FWIW: this was in meta-luneos for a while:
> https://github.com/webOS-ports/meta-webos-ports/blob/master/meta-luneos/recipes-devtools/smemstat/smemstat_git.bb
> 
> since 
> https://github.com/webOS-ports/meta-webos-ports/commit/9c73ce110a6cd97a476c6be
> ff10f9d8648cffea6

Ah, I could probably pick the install via make DESTDIR=${D}.

> I didn't compare the output from your version, but does it set the VERSION
> correctly now?

It seems to work:
root@qemux86-64:~# smemstat -h
smemstat, version 0.02.11
...

Regards,
Jan

> Regards,
> 
> On Tue, Feb 14, 2023 at 2:14 PM Jan Luebbe <jlu@pengutronix.de> wrote:
> > This is useful to see which processes use physical memory.
> > 
> > Signed-off-by: Jan Luebbe <jlu@pengutronix.de>
> > ---
> >  .../smemstat/smemstat_0.02.11.bb              | 27 +++++++++++++++++++
> >  1 file changed, 27 insertions(+)
> >  create mode 100644 meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
> > 
> > diff --git a/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb b/meta-
> > oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
> > new file mode 100644
> > index 000000000000..37015ce6bdc1
> > --- /dev/null
> > +++ b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
> > @@ -0,0 +1,27 @@
> > +SUMMARY = "smemstat reports the physical memory usage taking into
> > consideration shared memory"
> > +HOMEPAGE = "https://github.com/ColinIanKing/smemstat"
> > +LICENSE = "GPL-2.0-or-later"
> > +
> > +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> > +
> > +DEPENDS = "ncurses"
> > +
> > +SRC_URI =
> > "git://github.com/ColinIanKing/smemstat.git;protocol=https;branch=master"
> > +SRCREV = "9eea7504ab33783d804c4ed9237e299effb68874"
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +do_configure () {
> > +       :
> > +}
> > +
> > +do_compile () {
> > +       oe_runmake
> > +}
> > +
> > +do_install () {
> > +       install -d -m 755 ${D}${sbindir}
> > +       install -m 755 ${B}/smemstat ${D}${sbindir}/
> > +       install -d -m 755 ${D}${mandir}/man8
> > +       install -m 644 ${S}/smemstat.8 ${D}${mandir}/man8/
> > +}
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
new file mode 100644
index 000000000000..37015ce6bdc1
--- /dev/null
+++ b/meta-oe/recipes-devtools/smemstat/smemstat_0.02.11.bb
@@ -0,0 +1,27 @@ 
+SUMMARY = "smemstat reports the physical memory usage taking into consideration shared memory"
+HOMEPAGE = "https://github.com/ColinIanKing/smemstat"
+LICENSE = "GPL-2.0-or-later"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "ncurses"
+
+SRC_URI = "git://github.com/ColinIanKing/smemstat.git;protocol=https;branch=master"
+SRCREV = "9eea7504ab33783d804c4ed9237e299effb68874"
+
+S = "${WORKDIR}/git"
+
+do_configure () {
+	:
+}
+
+do_compile () {
+	oe_runmake
+}
+
+do_install () {
+	install -d -m 755 ${D}${sbindir}
+	install -m 755 ${B}/smemstat ${D}${sbindir}/
+	install -d -m 755 ${D}${mandir}/man8
+	install -m 644 ${S}/smemstat.8 ${D}${mandir}/man8/
+}