diff mbox series

[PATCHv6] graphene: add a PACKAGECONFIG for arm_neon

Message ID 20230214054310.4790-1-f_l_k@t-online.de
State Accepted, archived
Commit 72778f6a647f47926c6ba1b77f0984999a22e44a
Headers show
Series [PATCHv6] graphene: add a PACKAGECONFIG for arm_neon | expand

Commit Message

Markus Volk Feb. 14, 2023, 5:43 a.m. UTC
Not all arm platforms support neon and runtime detection for this feature is
currently not reliable.
Disable neon support by default on ARM-32 platforms because of the
following upstream bug: https://github.com/ebassi/graphene/issues/215

Enable neon for aarch64 by default

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-graphics/graphene/graphene_1.10.8.bb | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-graphics/graphene/graphene_1.10.8.bb b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
index 813ff74adf..75c8258d99 100644
--- a/meta/recipes-graphics/graphene/graphene_1.10.8.bb
+++ b/meta/recipes-graphics/graphene/graphene_1.10.8.bb
@@ -10,8 +10,12 @@  inherit gnomebase gobject-introspection gtk-doc
 SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a"
 
 # gtk4 & mutter 41.0 requires graphene build with introspection
-PACKAGECONFIG ?= "introspection"
+# Disable neon support by default on ARM-32 platforms because of the
+# following upstream bug: https://github.com/ebassi/graphene/issues/215
+PACKAGECONFIG ?= "introspection ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}"
+
 PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled,"
+PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false,"
 
 GTKDOC_MESON_OPTION = "gtk_doc"