[3/8] systemd: remove /var in nativesdk builds

Message ID 20211117123201.111905-4-luca.boccassi@gmail.com
State New
Headers show
Series systemd: allow building for nativesdk | expand

Commit Message

Luca Boccassi Nov. 17, 2021, 12:31 p.m. UTC
From: Luca Boccassi <luca.boccassi@microsoft.com>

Nothing picks it up, so it fails QA checks

Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
---
 meta/recipes-core/systemd/systemd_249.5.bb | 5 +++++
 1 file changed, 5 insertions(+)

Patch

diff --git a/meta/recipes-core/systemd/systemd_249.5.bb b/meta/recipes-core/systemd/systemd_249.5.bb
index 38a2f5d474..016058cd7f 100644
--- a/meta/recipes-core/systemd/systemd_249.5.bb
+++ b/meta/recipes-core/systemd/systemd_249.5.bb
@@ -772,6 +772,11 @@  ALTERNATIVE_TARGET[runlevel] = "${base_bindir}/systemctl"
 ALTERNATIVE_LINK_NAME[runlevel] = "${base_sbindir}/runlevel"
 ALTERNATIVE_PRIORITY[runlevel] ?= "300"
 
+# Nothing picks up /var in the nativesdk case
+do_install_append_class-nativesdk () {
+	rm -rf ${D}/var
+}
+
 pkg_postinst:${PN}:libc-glibc () {
 	if [ "${PN}" = "nativesdk-systemd" ]; then
 		exit 0