diff mbox series

[dunfell,RFC] conf: machine: j784s4-evm: Add support for J784S4 HS-FS

Message ID 20230213160344.174110-1-sabiya.d@ti.com
State RFC
Delegated to: Ryan Eatmon
Headers show
Series [dunfell,RFC] conf: machine: j784s4-evm: Add support for J784S4 HS-FS | expand

Commit Message

Dasnavis Sabiya Feb. 13, 2023, 4:03 p.m. UTC
From: Dasnavis Sabiya <sabiya.d@ti.com>

Add the basic J784S4 HS-FS configuration.
* Add configurations to support both HS-FS and GP and keep GP as default.
* Add ti-sci-firmware overrides for HS-FS.

Signed-off-by: Dasnavis Sabiya <sabiya.d@ti.com>
---
 conf/machine/j784s4-evm-k3r5-gp.conf        | 20 ++++++++++++++++++++
 conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf | 15 +++++++++++++++
 conf/machine/j784s4-evm.conf                | 13 ++++++++++---
 recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb      |  3 ++-
 4 files changed, 47 insertions(+), 4 deletions(-)
 create mode 100644 conf/machine/j784s4-evm-k3r5-gp.conf
 create mode 100644 conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf

Comments

Ryan Eatmon Feb. 14, 2023, 12:13 a.m. UTC | #1
First, you need to create the multiconfig files that you are referencing 
in the files:

conf/multiconfig/k3r5-sr1.conf
conf/multiconfig/k3r5-sr1-hs-fs.conf

Just copy what the sr2 files are doing and change the sr2 to sr1.


More comments inline....


On 2/13/2023 10:03, sabiya.d@mistralsolutions.com wrote:
> From: Dasnavis Sabiya <sabiya.d@ti.com>
> 
> Add the basic J784S4 HS-FS configuration.
> * Add configurations to support both HS-FS and GP and keep GP as default.
> * Add ti-sci-firmware overrides for HS-FS.
> 
> Signed-off-by: Dasnavis Sabiya <sabiya.d@ti.com>
> ---
>   conf/machine/j784s4-evm-k3r5-gp.conf        | 20 ++++++++++++++++++++
>   conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf | 15 +++++++++++++++
>   conf/machine/j784s4-evm.conf                | 13 ++++++++++---
>   recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb      |  3 ++-
>   4 files changed, 47 insertions(+), 4 deletions(-)
>   create mode 100644 conf/machine/j784s4-evm-k3r5-gp.conf
>   create mode 100644 conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf
> 
> diff --git a/conf/machine/j784s4-evm-k3r5-gp.conf b/conf/machine/j784s4-evm-k3r5-gp.conf
> new file mode 100644
> index 00000000..5fd47b70
> --- /dev/null
> +++ b/conf/machine/j784s4-evm-k3r5-gp.conf
> @@ -0,0 +1,20 @@
> +#@TYPE: Machine
> +#@NAME: J784S4 GP EVM (R5F)
> +#@DESCRIPTION: Machine configuration for the TI J784S4 GP EVM (R5F core)
> +
> +# Booting GP requires different SYSFW, the rest is handled at runtime
> +
> +require conf/machine/include/k3r5.inc
> +SOC_FAMILY_append = ":k3r5-gp"
> +
> +SYSFW_SOC = "j784s4"
> +SYSFW_CONFIG = "evm"
> +SYSFW_SUFFIX = "gp"
> +SYSFW_TIBOOT3_SYMLINK = "tiboot3.bin"
> +
> +UBOOT_MACHINE = "j784s4_evm_r5_defconfig"
> +
> +SPL_BINARY = ""
> +UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
> +UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
> +UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}"
> diff --git a/conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf b/conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf
> new file mode 100644
> index 00000000..8c77c910
> --- /dev/null
> +++ b/conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf
> @@ -0,0 +1,15 @@
> +#@TYPE: Machine
> +#@NAME: J784S4 HS-FS EVM (R5F)
> +#@DESCRIPTION: Machine configuration for the TI J784S4 HS-FS EVM (R5F core)
> +
> +# Booting HS-FS requires different SYSFW, the rest is handled at runtime
> +
> +require conf/machine/include/k3r5.inc
> +SOC_FAMILY_append = ":k3r5-sr1-hs-fs"
> +
> +SYSFW_SOC = "j784s4"
> +SYSFW_CONFIG = "evm"
> +SYSFW_SUFFIX = "hs-fs"
> +SYSFW_TIBOOT3_SYMLINK = ""

There are build errors with this patch.  k3-image-gen is configured to 
build sysfw for j784s4 so you need to configure the variables to not 
deploy the same files for all multiconfigs.  We do this by setting the 
following variable:

    SYSFW_SYMLINK = ""


> +
> +UBOOT_MACHINE = "j784s4_evm_r5_defconfig"
> diff --git a/conf/machine/j784s4-evm.conf b/conf/machine/j784s4-evm.conf
> index e892f597..c4548520 100644
> --- a/conf/machine/j784s4-evm.conf
> +++ b/conf/machine/j784s4-evm.conf
> @@ -39,8 +39,15 @@ KERNEL_DEVICETREE = " \
>   
>   UBOOT_MACHINE = "j784s4_evm_a72_defconfig"
>   
> -do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
> -do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
> +# Default tiboot3.bin on J784S4 is for GP
> +BBMULTICONFIG = "k3r5-gp"
> +do_image_wic[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
> +do_image_tar[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
>   
> -TFA_BOARD = "j784s4"
> +# Since default tiboot3.bin on J784S4 is for GP, add a version for SR1.0 HS-FS
> +BBMULTICONFIG += "k3r5-sr1-hs-fs"
> +IMAGE_BOOT_FILES += " tiboot3-j784s4-hs-fs-evm.bin"
> +do_image_wic[mcdepends] += "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
> +do_image_tar[mcdepends] += "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
>   
> +TFA_BOARD = "j784s4"
> diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> index cb197954..1bc8fab7 100644
> --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> @@ -36,7 +36,8 @@ SYSFW_PREFIX_j7200-hs-evm-k3r5 = "fs"
>   SYSFW_PREFIX_j721s2-evm-k3r5-gp = "fs"
>   SYSFW_PREFIX_j721s2-evm-k3r5-sr1-hs-fs = "fs"
>   SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
> -SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
> +SYSFW_PREFIX_j784s4-evm-k3r5-gp = "fs"
> +SYSFW_PREFIX_j784s4-evm-k3r5-sr1-hs-fs = "fs"
>   SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"
>   SYSFW_PREFIX_am62xx-evm-k3r5-gp = "fs"
>   SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs"
diff mbox series

Patch

diff --git a/conf/machine/j784s4-evm-k3r5-gp.conf b/conf/machine/j784s4-evm-k3r5-gp.conf
new file mode 100644
index 00000000..5fd47b70
--- /dev/null
+++ b/conf/machine/j784s4-evm-k3r5-gp.conf
@@ -0,0 +1,20 @@ 
+#@TYPE: Machine
+#@NAME: J784S4 GP EVM (R5F)
+#@DESCRIPTION: Machine configuration for the TI J784S4 GP EVM (R5F core)
+
+# Booting GP requires different SYSFW, the rest is handled at runtime
+
+require conf/machine/include/k3r5.inc
+SOC_FAMILY_append = ":k3r5-gp"
+
+SYSFW_SOC = "j784s4"
+SYSFW_CONFIG = "evm"
+SYSFW_SUFFIX = "gp"
+SYSFW_TIBOOT3_SYMLINK = "tiboot3.bin"
+
+UBOOT_MACHINE = "j784s4_evm_r5_defconfig"
+
+SPL_BINARY = ""
+UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
+UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK = "u-boot-r5spl-gp.${UBOOT_SUFFIX}"
diff --git a/conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf b/conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf
new file mode 100644
index 00000000..8c77c910
--- /dev/null
+++ b/conf/machine/j784s4-evm-k3r5-sr1-hs-fs.conf
@@ -0,0 +1,15 @@ 
+#@TYPE: Machine
+#@NAME: J784S4 HS-FS EVM (R5F)
+#@DESCRIPTION: Machine configuration for the TI J784S4 HS-FS EVM (R5F core)
+
+# Booting HS-FS requires different SYSFW, the rest is handled at runtime
+
+require conf/machine/include/k3r5.inc
+SOC_FAMILY_append = ":k3r5-sr1-hs-fs"
+
+SYSFW_SOC = "j784s4"
+SYSFW_CONFIG = "evm"
+SYSFW_SUFFIX = "hs-fs"
+SYSFW_TIBOOT3_SYMLINK = ""
+
+UBOOT_MACHINE = "j784s4_evm_r5_defconfig"
diff --git a/conf/machine/j784s4-evm.conf b/conf/machine/j784s4-evm.conf
index e892f597..c4548520 100644
--- a/conf/machine/j784s4-evm.conf
+++ b/conf/machine/j784s4-evm.conf
@@ -39,8 +39,15 @@  KERNEL_DEVICETREE = " \
 
 UBOOT_MACHINE = "j784s4_evm_a72_defconfig"
 
-do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
-do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
+# Default tiboot3.bin on J784S4 is for GP
+BBMULTICONFIG = "k3r5-gp"
+do_image_wic[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
+do_image_tar[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
 
-TFA_BOARD = "j784s4"
+# Since default tiboot3.bin on J784S4 is for GP, add a version for SR1.0 HS-FS
+BBMULTICONFIG += "k3r5-sr1-hs-fs"
+IMAGE_BOOT_FILES += " tiboot3-j784s4-hs-fs-evm.bin"
+do_image_wic[mcdepends] += "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
+do_image_tar[mcdepends] += "mc::k3r5-sr1-hs-fs:ti-sci-fw:do_deploy"
 
+TFA_BOARD = "j784s4"
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index cb197954..1bc8fab7 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -36,7 +36,8 @@  SYSFW_PREFIX_j7200-hs-evm-k3r5 = "fs"
 SYSFW_PREFIX_j721s2-evm-k3r5-gp = "fs"
 SYSFW_PREFIX_j721s2-evm-k3r5-sr1-hs-fs = "fs"
 SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
-SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
+SYSFW_PREFIX_j784s4-evm-k3r5-gp = "fs"
+SYSFW_PREFIX_j784s4-evm-k3r5-sr1-hs-fs = "fs"
 SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"
 SYSFW_PREFIX_am62xx-evm-k3r5-gp = "fs"
 SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs"