diff mbox series

[meta-ti,dunfell,V2,2/2] am62xx-lp-evm: Add AM62x LP HS-FS evm configuration

Message ID 20230213145614.3840239-1-c-shilwant@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell,V2,1/2] am62xx-evm: Add AM62x HS-FS evm configuration | expand

Commit Message

Chirag Shilwant Feb. 13, 2023, 2:56 p.m. UTC
Lets add the basic AM62x LP HS-FS configuration
- Add machine conf for AM62x LP HS-FS.
- The wic images will boot on AM62x LP HS-FS devices by default. The sysfw image for HS-SE will be packaged in the wic image as tiboot3-am62x-hs-evm.bin.
- Add ti-sci-firmware overrides.

Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
---
 conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf | 14 ++++++++++++++
 conf/machine/am62xx-lp-evm-k3r5-hs-se.conf |  7 +++++++
 conf/machine/include/am62xx-lp.inc         |  8 +++++++-
 recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb     |  1 +
 4 files changed, 29 insertions(+), 1 deletion(-)
 create mode 100644 conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf
diff mbox series

Patch

diff --git a/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf b/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf
new file mode 100644
index 00000000..0178fcfc
--- /dev/null
+++ b/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf
@@ -0,0 +1,14 @@ 
+#@TYPE: Machine
+#@NAME: AM62xx LPSK HS-FS EVM (R5F)
+#@DESCRIPTION: Machine configuration for the TI AM62xx LP HS-FS EVM (R5F core)
+
+# Booting HS-FS requires different SYSFW, the rest is handled at runtime
+
+require conf/machine/include/k3r5.inc
+SOC_FAMILY_append = ":k3r5-hs-fs"
+
+SYSFW_SOC = "am62x"
+SYSFW_CONFIG = "evm"
+SYSFW_SUFFIX = "hs-fs"
+
+UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
diff --git a/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf b/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
index b752ee7e..b44cbe20 100644
--- a/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
+++ b/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
@@ -11,4 +11,11 @@  SYSFW_SOC = "am62x"
 SYSFW_CONFIG = "evm"
 SYSFW_SUFFIX = "hs"
 
+SYSFW_TIBOOT3_SYMLINK = ""
+
 UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
+
+SPL_BINARY = ""
+UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
+UBOOT_IMAGE = "u-boot-r5spl-hs-se-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK = "u-boot-r5spl-hs-se.${UBOOT_SUFFIX}"
diff --git a/conf/machine/include/am62xx-lp.inc b/conf/machine/include/am62xx-lp.inc
index c38de868..02937662 100644
--- a/conf/machine/include/am62xx-lp.inc
+++ b/conf/machine/include/am62xx-lp.inc
@@ -8,8 +8,14 @@  SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
 
 TFA_K3_SYSTEM_SUSPEND = "1"
 
-# Default tiboot3.bin on AM62x LP is for HS-SE
+# Default tiboot3.bin on AM62x LP is for HS-FS
+BBMULTICONFIG = "k3r5-hs-fs"
+do_image_wic[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
+do_image_tar[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
+
+# Since default tiboot3.bin on AM62x LP is for HS-FS, add a version for HS-SE
 BBMULTICONFIG += "k3r5-hs-se"
+IMAGE_BOOT_FILES += " tiboot3-am62x-hs-evm.bin"
 do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
 do_image_tar[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
 
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 7d046750..643a2ab3 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -42,6 +42,7 @@  SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs"
 SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs"
 SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
 SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
+SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs"
 SYSFW_PREFIX_am62axx-evm-k3r5 = "fs"
 
 SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"