diff mbox series

[langdale,06/28] python3-pytest: depend on python3-tomli instead of python3-toml

Message ID 04e31f0035ad29afc3cdcf9730cd76cd725b8a20.1676150527.git.steve@sakoman.com
State New
Headers show
Series [langdale,01/28] git: ignore CVE-2022-41953 | expand

Commit Message

Steve Sakoman Feb. 11, 2023, 9:23 p.m. UTC
From: Arnout Vandecappelle <arnout@mind.be>

Since version 7.0.0 [1], pytest switched from the toml package to the
tomli package for parsing pyproject.toml configuration files [2].

This change is not immediately noticable during tests, because the
toml/tomli module is only important if a pyproject.toml is actually
present in a project.

[1] https://docs.pytest.org/en/latest/changelog.html#pytest-7-0-0rc1-2021-12-06
[2] https://github.com/pytest-dev/pytest/issues/8789

Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-devtools/python/python3-pytest_7.1.3.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pytest_7.1.3.bb b/meta/recipes-devtools/python/python3-pytest_7.1.3.bb
index 373f7f35fa..9710242655 100644
--- a/meta/recipes-devtools/python/python3-pytest_7.1.3.bb
+++ b/meta/recipes-devtools/python/python3-pytest_7.1.3.bb
@@ -26,7 +26,7 @@  RDEPENDS:${PN}:class-target += " \
     ${PYTHON_PN}-py \
     ${PYTHON_PN}-setuptools \
     ${PYTHON_PN}-six \
-    ${PYTHON_PN}-toml \
+    ${PYTHON_PN}-tomli \
     ${PYTHON_PN}-wcwidth \
 "