diff mbox series

[v2,1/2] python3-dtschema: add dependency on pylibfdt

Message ID 20230210142539.28035-1-twoerner@gmail.com
State New
Headers show
Series [v2,1/2] python3-dtschema: add dependency on pylibfdt | expand

Commit Message

Trevor Woerner Feb. 10, 2023, 2:25 p.m. UTC
dt-schema has a dependency on pylibfdt.

Signed-off-by: Trevor Woerner <twoerner@gmail.com>
---
changes since v1:
- add a maintainer entry
---
 meta/conf/distro/include/maintainers.inc           |  1 +
 .../python/python3-dtschema_2023.1.bb              |  2 +-
 .../python/python3-pylibfdt_1.6.1.bb               | 14 ++++++++++++++
 3 files changed, 16 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb

Comments

Bruce Ashfield Feb. 10, 2023, 5:44 p.m. UTC | #1
On Fri, Feb 10, 2023 at 9:25 AM Trevor Woerner <twoerner@gmail.com> wrote:
>
> dt-schema has a dependency on pylibfdt.
>

FWIW. I find that the pypi libfdt lags quite a bit, and isn't updated
often (that being said, there aren't really updates in dtc either, so
it probably isn't an issue).

When I've been building it for supporting my other projects, I've
ended up using the main dtc git, and meson to do the build and
install.

Bruce

> Signed-off-by: Trevor Woerner <twoerner@gmail.com>
> ---
> changes since v1:
> - add a maintainer entry
> ---
>  meta/conf/distro/include/maintainers.inc           |  1 +
>  .../python/python3-dtschema_2023.1.bb              |  2 +-
>  .../python/python3-pylibfdt_1.6.1.bb               | 14 ++++++++++++++
>  3 files changed, 16 insertions(+), 1 deletion(-)
>  create mode 100644 meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
>
> diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
> index ec7ea90d16a6..575ceac8f23c 100644
> --- a/meta/conf/distro/include/maintainers.inc
> +++ b/meta/conf/distro/include/maintainers.inc
> @@ -661,6 +661,7 @@ RECIPE_MAINTAINER:pn-python3-pycparser = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-pyelftools = "Joshua Watt <JPEWhacker@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-pygments = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
>  RECIPE_MAINTAINER:pn-python3-pygobject = "Zang Ruochen <zangrc.fnst@fujitsu.com>"
> +RECIPE_MAINTAINER:pn-python3-pylibfdt = "Trevor Woerner <twoerner@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-pyopenssl = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-pyparsing = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
>  RECIPE_MAINTAINER:pn-python3-pyproject-hooks = "Ross Burton <ross.burton@arm.com>"
> diff --git a/meta/recipes-devtools/python/python3-dtschema_2023.1.bb b/meta/recipes-devtools/python/python3-dtschema_2023.1.bb
> index 9767c95d3043..24bded9710a9 100644
> --- a/meta/recipes-devtools/python/python3-dtschema_2023.1.bb
> +++ b/meta/recipes-devtools/python/python3-dtschema_2023.1.bb
> @@ -10,6 +10,6 @@ PYPI_PACKAGE = "dtschema"
>  SRC_URI[sha256sum] = "8fc8c269e4c57e9d008af7b32cd33b77afd4ea1ac9552bcfa96b41b9e0c52586"
>
>  DEPENDS += "python3-setuptools-scm-native"
> -RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
> +RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987 python3-pylibfdt"
>
>  BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
> new file mode 100644
> index 000000000000..966f8f1413fb
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
> @@ -0,0 +1,14 @@
> +DESCRIPTION = "libfdt from the dtc project"
> +HOMEPAGE = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
> +LICENSE = "BSD-2-Clause"
> +LIC_FILES_CHKSUM = "file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927"
> +
> +inherit pypi setuptools3
> +
> +PYPI_PACKAGE = "pylibfdt"
> +
> +SRC_URI[sha256sum] = "90c667c5adf44c6ab2f13bdc566598897784c7b781bed91064e7373bd270b778"
> +
> +DEPENDS += "python3-setuptools-scm-native swig-native"
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.36.0.rc2.17.g4027e30c53
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#176993): https://lists.openembedded.org/g/openembedded-core/message/176993
> Mute This Topic: https://lists.openembedded.org/mt/96876890/1050810
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Trevor Woerner Feb. 12, 2023, 8:51 p.m. UTC | #2
Hi Bruce,

On Fri 2023-02-10 @ 12:44:12 PM, Bruce Ashfield wrote:
> On Fri, Feb 10, 2023 at 9:25 AM Trevor Woerner <twoerner@gmail.com> wrote:
> >
> > dt-schema has a dependency on pylibfdt.
> >
> 
> FWIW. I find that the pypi libfdt lags quite a bit, and isn't updated
> often (that being said, there aren't really updates in dtc either, so
> it probably isn't an issue).
> 
> When I've been building it for supporting my other projects, I've
> ended up using the main dtc git, and meson to do the build and
> install.

One source base builds both dtc and pylibfdt.
The latest release of dtc is 1.7.0.
The dtc recipe in oecore is 1.6.1
The pypi index has an entry for pylibfdt 1.6.1, for which I've added a recipe.

I've been kicking around a couple things and could use some input. On the one
hand I tweaked the dtc_1.6.1 recipe in oecore to update it to dtc_1.7.0. I
also added metadata to additionally generate pylibfdt_1.7.0 from within the
same dtc_1.7.0 recipe, controlled by a PACKAGECONFIG.

How would you prefer to go forward?
- (I assume you would be happy to take an update of dtc_1.6.1 to dtc_1.7.0)
- updating dtc to also generate a python3-pylibfdt package
  - should this be controlled by a PACKAGECONFIG? or be build unconditionally?
- creating a separate python3-pylibfdt_1.7.0 recipe that uses the same sources
  but only generates the python3-pylibfdt package

I can put together a v3 when I know which path you'd prefer.

Best regards,
	Trevor
diff mbox series

Patch

diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index ec7ea90d16a6..575ceac8f23c 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -661,6 +661,7 @@  RECIPE_MAINTAINER:pn-python3-pycparser = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-pyelftools = "Joshua Watt <JPEWhacker@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-pygments = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
 RECIPE_MAINTAINER:pn-python3-pygobject = "Zang Ruochen <zangrc.fnst@fujitsu.com>"
+RECIPE_MAINTAINER:pn-python3-pylibfdt = "Trevor Woerner <twoerner@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-pyopenssl = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-pyparsing = "Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>"
 RECIPE_MAINTAINER:pn-python3-pyproject-hooks = "Ross Burton <ross.burton@arm.com>"
diff --git a/meta/recipes-devtools/python/python3-dtschema_2023.1.bb b/meta/recipes-devtools/python/python3-dtschema_2023.1.bb
index 9767c95d3043..24bded9710a9 100644
--- a/meta/recipes-devtools/python/python3-dtschema_2023.1.bb
+++ b/meta/recipes-devtools/python/python3-dtschema_2023.1.bb
@@ -10,6 +10,6 @@  PYPI_PACKAGE = "dtschema"
 SRC_URI[sha256sum] = "8fc8c269e4c57e9d008af7b32cd33b77afd4ea1ac9552bcfa96b41b9e0c52586"
 
 DEPENDS += "python3-setuptools-scm-native"
-RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
+RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987 python3-pylibfdt"
 
 BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
new file mode 100644
index 000000000000..966f8f1413fb
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pylibfdt_1.6.1.bb
@@ -0,0 +1,14 @@ 
+DESCRIPTION = "libfdt from the dtc project"
+HOMEPAGE = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "pylibfdt"
+
+SRC_URI[sha256sum] = "90c667c5adf44c6ab2f13bdc566598897784c7b781bed91064e7373bd270b778"
+
+DEPENDS += "python3-setuptools-scm-native swig-native"
+
+BBCLASSEXTEND = "native nativesdk"