diff mbox series

[meta-python] python3-paramiko: upgrade 2.12.0 -> 3.0.0

Message ID 1675844052-11401-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-paramiko: upgrade 2.12.0 -> 3.0.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 8, 2023, 8:14 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Bubfix:
==========
-A handful of lower-level classes (notably paramiko.message.Message and
 paramiko.pkey.PKey) previously returned bytes objects from their
 implementation of __str__, even under Python 3; and there was never any
 __bytes__ method.

-Streamline some redundant (and costly) byte conversion calls in the packetizer
 and the core SFTP module. This should lead to some SFTP speedups at the very least.

-Remove some unnecessary __repr__ calls when handling bytes-vs-str conversions.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-paramiko_2.12.0.bb => python3-paramiko_3.0.0.bb}   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-paramiko_2.12.0.bb => python3-paramiko_3.0.0.bb} (82%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-paramiko_2.12.0.bb b/meta-python/recipes-devtools/python/python3-paramiko_3.0.0.bb
similarity index 82%
rename from meta-python/recipes-devtools/python/python3-paramiko_2.12.0.bb
rename to meta-python/recipes-devtools/python/python3-paramiko_3.0.0.bb
index 6295c66a2..9e79c3668 100644
--- a/meta-python/recipes-devtools/python/python3-paramiko_2.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-paramiko_3.0.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/paramiko/paramiko/"
 LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fd0120fc2e9f841c73ac707a30389af5"
 
-SRC_URI[sha256sum] = "376885c05c5d6aa6e1f4608aac2a6b5b0548b1add40274477324605903d9cd49"
+SRC_URI[sha256sum] = "fedc9b1dd43bc1d45f67f1ceca10bc336605427a46dcdf8dec6bfea3edf57965"
 
 PYPI_PACKAGE = "paramiko"