diff mbox series

[meta-python,kirkstone,2/6] python3-pillow: upgrade 9.1.1 -> 9.2.0

Message ID 20230131230851.2785067-2-Randy.MacLeod@windriver.com
State New
Headers show
Series [meta-python,kirkstone,1/6] python3-pillow: upgrade 9.0.1 -> 9.1.1 | expand

Commit Message

Randy MacLeod Jan. 31, 2023, 11:08 p.m. UTC
From: zhengruoqin <zhengrq.fnst@fujitsu.com>

Changelog:
=========

    Fixed null check for fribidi_version_info in FriBiDi shim
    Added GIF decompression bomb check
    Handle PCF fonts files with less than 256 characters
    Improved GIF optimize condition
    Reverted to array_interface with the release of NumPy 1.23
    Pad PCX palette to 768 bytes when saving
    Fixed bug with rounding pixels to palette colors
    Use gnome-screenshot on Linux if available
    Fixed loading L mode BMP RLE8 images
    Fixed incorrect operator in ImageCms error
    Limit FPX tile size to avoid extending outside image
    Added support for decoding plain PPM formats
    Added apply_transparency()
    Fixed behaviour change from endian fix
    Use python3
    Allow remapping P images with RGBA palettes
    Revert "Skip test_realloc_overflow unless libtiff 4.0.4 or higher"
    [pre-commit.ci] pre-commit autoupdate
    Only import ImageFont in ImageDraw when necessary
    Fixed drawing translucent 1px high polygons
    Pad COLORMAP to 768 items when saving TIFF
    Fix P -> PA conversion
    Once exif data is parsed, do not reload unless it changes
    Only try to connect discontiguous corners at the end of edges
    Improve transparency handling when saving GIF images
    Do not update GIF frame position until local image is found
    Netscape GIF extension belongs after the global color table
    Only write GIF comments at the beginning of the file
    Separate multiple GIF comment blocks with newlines
    Always use GIF89a for comments
    Ignore compression value from BMP info dictionary when saving as TIFF
    If font is file-like object, do not re-read from object to get variant
    Raise ValueError when trying to access internal fp after close
    Support more affine expression forms in im.point()
    Include 'twine check' in 'make sdist'
    Ensure that furthest v is set in quantize2

Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../{python3-pillow_9.1.1.bb => python3-pillow_9.2.0.bb}      | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pillow_9.1.1.bb => python3-pillow_9.2.0.bb} (88%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.1.1.bb b/meta-python/recipes-devtools/python/python3-pillow_9.2.0.bb
similarity index 88%
rename from meta-python/recipes-devtools/python/python3-pillow_9.1.1.bb
rename to meta-python/recipes-devtools/python/python3-pillow_9.2.0.bb
index 00df22a3d..454d61a48 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_9.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_9.2.0.bb
@@ -5,7 +5,7 @@  HOMEPAGE = "https://pillow.readthedocs.io"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ad081a0aede51e89f8da13333a8fb849"
 
-SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=9.1.x;protocol=https \
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=9.2.x;protocol=https \
            file://0001-support-cross-compiling.patch \
            file://0001-explicitly-set-compile-options.patch \
            "
@@ -39,4 +39,4 @@  RPROVIDES:${PN} += "python3-imaging"
 
 BBCLASSEXTEND = "native"
 
-SRCREV = "0f44136e720cd3b2db72bdf29614897b7aa3e868"
+SRCREV = "58acec3312fb8671c9d84829197e1c8150085589"