diff mbox series

[meta-ti,dunfell,v1] optee: update optee components to 3.20 tag

Message ID 20230131052053.3759470-1-m-chawdhry@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell,v1] optee: update optee components to 3.20 tag | expand

Commit Message

Manorit Chawdhry Jan. 31, 2023, 5:20 a.m. UTC
OPTEE tests is not being upgraded due to a newer python dependency for
the build

Signed-off-by: Manorit Chawdhry <m-chawdhry@ti.com>
---
 recipes-security/optee/optee-client_%.bbappend   | 9 ++++++---
 recipes-security/optee/optee-examples_%.bbappend | 4 ++--
 recipes-security/optee/optee-os_%.bbappend       | 4 ++--
 3 files changed, 10 insertions(+), 7 deletions(-)

Comments

Ryan Eatmon Feb. 6, 2023, 2:51 p.m. UTC | #1
Ok.  It was my fault for accepting this patch without doing all of the 
test builds that I normally do and having to revert it.  This is what 
happens when you rush.

On 1/30/2023 23:20, Manorit Chawdhry wrote:
> OPTEE tests is not being upgraded due to a newer python dependency for
> the build
> 
> Signed-off-by: Manorit Chawdhry <m-chawdhry@ti.com>
> ---
>   recipes-security/optee/optee-client_%.bbappend   | 9 ++++++---
>   recipes-security/optee/optee-examples_%.bbappend | 4 ++--
>   recipes-security/optee/optee-os_%.bbappend       | 4 ++--
>   3 files changed, 10 insertions(+), 7 deletions(-)
> 
> diff --git a/recipes-security/optee/optee-client_%.bbappend b/recipes-security/optee/optee-client_%.bbappend
> index a8adef47..0ede4898 100644
> --- a/recipes-security/optee/optee-client_%.bbappend
> +++ b/recipes-security/optee/optee-client_%.bbappend
> @@ -1,4 +1,7 @@
> -PV_ti-soc = "3.19.0+git${SRCPV}"
> -SRCREV_ti-soc = "140bf463046071d3ca5ebbde3fb21ee0854e1951"
> +PV_ti-soc = "3.20.0+git${SRCPV}"
> +SRCREV_ti-soc = "dd2d39b49975d2ada7870fe2b7f5a84d0d3860dc"
>   
> -DEPENDS_append_ti-soc = "pkgconfig util-linux"
> +inherit pkgconfig
> +DEPENDS_append_ti-soc = "util-linux"
> +
> +EXTRA_OEMAKE_append_k3 = " PKG_CONFIG=pkg-config"


The above line is locking down the PKG_CONFIG change to just k3 parts. 
It should be based on ti-soc like all of the other overrides in the file.

Please make that change and submit a v2.



> diff --git a/recipes-security/optee/optee-examples_%.bbappend b/recipes-security/optee/optee-examples_%.bbappend
> index dda7cbbf..ef6da34e 100644
> --- a/recipes-security/optee/optee-examples_%.bbappend
> +++ b/recipes-security/optee/optee-examples_%.bbappend
> @@ -1,5 +1,5 @@
> -PV_ti-soc = "3.19.0+git${SRCPV}"
> -SRCREV_ti-soc = "f301ee9df2129c0db683e726c91dc2cefe4cdb65"
> +PV_ti-soc = "3.20.0+git${SRCPV}"
> +SRCREV_ti-soc = "a98d01e1b9168eaed96bcd0bac0df67c44a81081"
>   SRC_URI_ti-soc = "git://github.com/linaro-swg/optee_examples.git;protocol=https"
>   
>   DEPENDS_append_ti-soc = " python3-cryptography-native"
> diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
> index db9064de..a77fbc5a 100644
> --- a/recipes-security/optee/optee-os_%.bbappend
> +++ b/recipes-security/optee/optee-os_%.bbappend
> @@ -1,5 +1,5 @@
> -PV_ti-soc = "3.19.0+git${SRCPV}"
> -SRCREV_ti-soc = "d6c5d0037b46f46caf71d67d7825d4b722cbcddf"
> +PV_ti-soc = "3.20.0+git${SRCPV}"
> +SRCREV_ti-soc = "3bc3809afe372ca7e8216fc5d7a64e965bb4ad70"
>   SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https"
>   
>   DEPENDS_append_ti-soc = " python3-cryptography-native"
diff mbox series

Patch

diff --git a/recipes-security/optee/optee-client_%.bbappend b/recipes-security/optee/optee-client_%.bbappend
index a8adef47..0ede4898 100644
--- a/recipes-security/optee/optee-client_%.bbappend
+++ b/recipes-security/optee/optee-client_%.bbappend
@@ -1,4 +1,7 @@ 
-PV_ti-soc = "3.19.0+git${SRCPV}"
-SRCREV_ti-soc = "140bf463046071d3ca5ebbde3fb21ee0854e1951"
+PV_ti-soc = "3.20.0+git${SRCPV}"
+SRCREV_ti-soc = "dd2d39b49975d2ada7870fe2b7f5a84d0d3860dc"
 
-DEPENDS_append_ti-soc = "pkgconfig util-linux"
+inherit pkgconfig
+DEPENDS_append_ti-soc = "util-linux"
+
+EXTRA_OEMAKE_append_k3 = " PKG_CONFIG=pkg-config"
diff --git a/recipes-security/optee/optee-examples_%.bbappend b/recipes-security/optee/optee-examples_%.bbappend
index dda7cbbf..ef6da34e 100644
--- a/recipes-security/optee/optee-examples_%.bbappend
+++ b/recipes-security/optee/optee-examples_%.bbappend
@@ -1,5 +1,5 @@ 
-PV_ti-soc = "3.19.0+git${SRCPV}"
-SRCREV_ti-soc = "f301ee9df2129c0db683e726c91dc2cefe4cdb65"
+PV_ti-soc = "3.20.0+git${SRCPV}"
+SRCREV_ti-soc = "a98d01e1b9168eaed96bcd0bac0df67c44a81081"
 SRC_URI_ti-soc = "git://github.com/linaro-swg/optee_examples.git;protocol=https"
 
 DEPENDS_append_ti-soc = " python3-cryptography-native"
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index db9064de..a77fbc5a 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -1,5 +1,5 @@ 
-PV_ti-soc = "3.19.0+git${SRCPV}"
-SRCREV_ti-soc = "d6c5d0037b46f46caf71d67d7825d4b722cbcddf"
+PV_ti-soc = "3.20.0+git${SRCPV}"
+SRCREV_ti-soc = "3bc3809afe372ca7e8216fc5d7a64e965bb4ad70"
 SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https"
 
 DEPENDS_append_ti-soc = " python3-cryptography-native"