diff mbox series

[3/3] arm-bsp/corstone1000-image: Generate UEFI capsule for corstone1000 platform

Message ID 20230127192122.19338-4-gowtham.sureshkumar@arm.com
State New
Headers show
Series Add UEFI capsule generation support | expand

Commit Message

Gowtham Suresh Kumar Jan. 27, 2023, 7:21 p.m. UTC
From: Gowtham Suresh Kumar <gowtham.sureshkumar@arm.com>

Inherits the UEFI capsule generation class and configures the capsule
variables for the wic.nopt image

Signed-off-by: Gowtham Suresh Kumar <gowtham.sureshkumar@arm.com>
---
 meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb b/meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb
index 76a7126b..b0a71bca 100644
--- a/meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb
+++ b/meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb
@@ -7,10 +7,17 @@  COMPATIBLE_MACHINE = "corstone1000"
 
 inherit image
 inherit wic_nopt tfm_sign_image
+inherit  uefi_capsule
 
 PACKAGE_INSTALL = ""
 
-IMAGE_FSTYPES += "wic wic.nopt"
+IMAGE_FSTYPES += "wic wic.nopt uefi_capsule"
+
+UEFI_FIRMWARE_BINARY = "corstone1000-image-${MACHINE}.wic.nopt"
+UEFI_FIRMWARE_VERSION = "5"
+UEFI_FIRMWARE_LSV = "0"
+UEFI_FIRMWARE_GUID = "e2bb9c06-70e9-4b14-97a3-5a7913176e3f"
+UEFI_FIRMWARE_UPDATE_INDEX = "0"
 
 do_sign_images() {
     # Sign TF-A BL2