diff mbox series

make-mod-scripts: Ensure kernel build output is deterministic

Message ID 20230127102729.2623316-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 0d79d4883f924cef0d0ba361506ad75d441b9721
Headers show
Series make-mod-scripts: Ensure kernel build output is deterministic | expand

Commit Message

Richard Purdie Jan. 27, 2023, 10:27 a.m. UTC
The definitions in linux-kernel-base are needed to ensure the generated headers
are consistent. This was a small step that was missing from the previous
changes to linux-kernel-base as both kernel-devsrc and make-mod-scripts
need this information defined consistently.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Bruce Ashfield Jan. 27, 2023, 1:44 p.m. UTC | #1
On Fri, Jan 27, 2023 at 5:27 AM Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
>
> The definitions in linux-kernel-base are needed to ensure the generated headers
> are consistent. This was a small step that was missing from the previous
> changes to linux-kernel-base as both kernel-devsrc and make-mod-scripts
> need this information defined consistently.
>

Aha! yes, another spot that the generation of header files could be triggered.

It was more likely this recipe that was doing the clobbering,
triggered by devsrc and racing with the kernel. Since devsrc doesn't
do any building, i couldn't find a path where it did it alone.

I consider this the root cause, when coupled with 6.1 doing more
aggressive generation of the headers than previous kernel versions.

Bruce

> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>  meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
> index 9afd6714f0d..38282e58f10 100644
> --- a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
> +++ b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
> @@ -3,7 +3,7 @@ HOMEPAGE = "https://www.yoctoproject.org/"
>  LICENSE = "GPL-2.0-only"
>  LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
>
> -inherit kernel-arch
> +inherit kernel-arch linux-kernel-base
>  inherit pkgconfig
>
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
> --
> 2.37.2
>
diff mbox series

Patch

diff --git a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
index 9afd6714f0d..38282e58f10 100644
--- a/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
+++ b/meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://www.yoctoproject.org/"
 LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
 
-inherit kernel-arch
+inherit kernel-arch linux-kernel-base
 inherit pkgconfig
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"