diff mbox series

[meta-python,2/2] python3-nocasedict: Upgrade 1.0.4 -> 1.1.0

Message ID 20230124160119.377481-2-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/2] python3-nocaselist: Upgrade 1.0.6 -> 1.1.0 | expand

Commit Message

Leon Anavi Jan. 24, 2023, 4:01 p.m. UTC
Upgrade to release 1.1.0:

- The default casefolding method on Python 3 was changed from
  str.lower() to str.casefold(). This changes the matching of the
  case-insensitive keys. This shold normally be an improvement,
  but in case you find that you are negatively affected by this
  change, you can go back to the str.lower() method by overriding
  the NocaseDict.__casefold__() method with a method that calls
  str.lower().
- Added support for Python 3.11.
- Changed the default casefolding method on Python 3 to be
  str.casefold() in order to improve Unicode support. On Python 2,
  it remains str.lower(). Added support for user-defined
  casefolding.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...{python3-nocasedict_1.0.4.bb => python3-nocasedict_1.1.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-nocasedict_1.0.4.bb => python3-nocasedict_1.1.0.bb} (76%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-nocasedict_1.0.4.bb b/meta-python/recipes-devtools/python/python3-nocasedict_1.1.0.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-nocasedict_1.0.4.bb
rename to meta-python/recipes-devtools/python/python3-nocasedict_1.1.0.bb
index 006799c8b..319598e3b 100644
--- a/meta-python/recipes-devtools/python/python3-nocasedict_1.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-nocasedict_1.1.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/pywbem/nocasedict"
 LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742"
 
-SRC_URI[sha256sum] = "7c111da4cefd244433cb63377aff081a40f84bddae9e6f376c67f086c0f806da"
+SRC_URI[sha256sum] = "ac551de692be6aea5b43ac3f2c33780df940013ac6dd0718fb552c8b560ba661"
 
 inherit pypi setuptools3