diff mbox series

[meta-python] python3-greenlet: Drop using register keyword

Message ID 20230117162916.3917024-1-raj.khem@gmail.com
State New
Headers show
Series [meta-python] python3-greenlet: Drop using register keyword | expand

Commit Message

Khem Raj Jan. 17, 2023, 4:29 p.m. UTC
Its gone in modern C/C++ since c++17

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...using-register-storage-class-keyword.patch | 31 +++++++++++++++++++
 .../python/python3-greenlet_2.0.1.bb          |  2 ++
 2 files changed, 33 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch b/meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch
new file mode 100644
index 0000000000..5abe59279f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-greenlet/0001-greenlet-Drop-using-register-storage-class-keyword.patch
@@ -0,0 +1,31 @@ 
+From aa505359a3bb5a954fe3c7fbd853c75802bf3533 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 16 Jan 2023 21:37:26 -0800
+Subject: [PATCH] greenlet: Drop using 'register' storage class keyword
+
+This has been dropped in c++17 and newer
+
+Upstream-Status: Submitted [https://github.com/python-greenlet/greenlet/pull/336]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/greenlet/platform/switch_riscv_unix.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/greenlet/platform/switch_riscv_unix.h b/src/greenlet/platform/switch_riscv_unix.h
+index 5b5ea98..24df9db 100644
+--- a/src/greenlet/platform/switch_riscv_unix.h
++++ b/src/greenlet/platform/switch_riscv_unix.h
+@@ -11,8 +11,8 @@
+ static int
+ slp_switch(void)
+ {
+-  register int ret;
+-  register long *stackref, stsizediff;
++  int ret;
++  long *stackref, stsizediff;
+   __asm__ volatile ("" : : : REGS_TO_SAVE);
+   __asm__ volatile ("mv %0, sp" : "=r" (stackref) : );
+   {
+-- 
+2.39.0
+
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_2.0.1.bb b/meta-python/recipes-devtools/python/python3-greenlet_2.0.1.bb
index 629d9d359f..4a50a24184 100644
--- a/meta-python/recipes-devtools/python/python3-greenlet_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-greenlet_2.0.1.bb
@@ -4,6 +4,8 @@  LICENSE = "MIT & PSF-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \
                     file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
 
+SRC_URI += "file://0001-greenlet-Drop-using-register-storage-class-keyword.patch"
+
 SRC_URI[sha256sum] = "42e602564460da0e8ee67cb6d7236363ee5e131aa15943b6670e44e5c2ed0f67"
 
 inherit pypi setuptools3