diff mbox series

[meta-python] python3-pyzmq: upgrade 24.0.1 -> 25.0.0

Message ID 1673940264-20487-3-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python] python3-pyzmq: upgrade 24.0.1 -> 25.0.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 17, 2023, 7:24 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
New:
------
- Added socket_class argument to zmq.Context.socket()
- Support shadowing sockets with socket objects, not just via address,
  e.g. zmq.asyncio.Socket(other_socket). Shadowing an object preserves a
  reference to the original, unlike shadowing via address.
- in zmq.auth, CredentialsProvider callbacks may now be async.
- ZMQStream callbacks may now be async.
- Add zmq.ReconnectStop draft constants.
- Add manylinux_2_28 wheels for x86_64 CPython 3.10, 3.11, and PyPy 3.9
  (these are in addition to not instead of the manylinux_2014 wheels).

Fixed:
-------
- When ZMQStream is given an async socket, it now warns and hooks up events
  correctly with the underlying socket, so the callback gets the received
  message, instead of sending the callback the incorrect arguments.
- Fixed toml parse error in pyproject.toml, when installing from source with
  very old pip.
- Removed expressed dependency on py when running with pypy, which hasn't
  been used in some time.

Deprecated:
----------
- zmq.auth.ioloop.IOLoopAuthenticator is deprecated in favor of
  zmq.auth.asyncio.AsyncioAuthenticator
- As part of migrating toward modern pytest, zmq.tests.BaseZMQTestCase
  is deprecated and should not be used outside pyzmq.
- python setup.py test is deprecated as a way to launch the tests.
  Just use pytest.

Removed:
----------
- Bundled subset of tornado's IOLoop (deprecated since pyzmq 17) is
  removed, so ZMQStream cannot be used without an actual install of tornado.
- Remove support for tornado 4, meaning tornado is always assumed to run on asyncio.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-pyzmq_24.0.1.bb => python3-pyzmq_25.0.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pyzmq_24.0.1.bb => python3-pyzmq_25.0.0.bb} (94%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_24.0.1.bb b/meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb
similarity index 94%
rename from meta-python/recipes-devtools/python/python3-pyzmq_24.0.1.bb
rename to meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb
index b3b0aefe1..39a7614fc 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_24.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_25.0.0.bb
@@ -13,7 +13,7 @@  SRC_URI:append = " \
     file://club-rpath-out.patch \
     file://run-ptest \
 "
-SRC_URI[sha256sum] = "216f5d7dbb67166759e59b0479bca82b8acf9bed6015b526b8eb10143fb08e77"
+SRC_URI[sha256sum] = "f330a1a2c7f89fd4b0aa4dcb7bf50243bf1c8da9a2f1efc31daf57a2046b31f2"
 
 inherit pypi pkgconfig python_setuptools_build_meta ptest