diff mbox series

[meta-python] tftpy: Add it for python tftp server and client

Message ID 20230113084856.37771-1-liezhi.yang@windriver.com
State Under Review
Headers show
Series [meta-python] tftpy: Add it for python tftp server and client | expand

Commit Message

Robert Yang Jan. 13, 2023, 8:48 a.m. UTC
Tftpy is a TFTP library for the Python programming language. It includes client
and server classes, with sample implementations. Hooks are included for easy
inclusion in a UI for populating progress indicators. It supports RFCs 1350,
2347, 2348 and the tsize option from RFC 2349.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
 meta-python/recipes-devtools/python/tftpy_0.8.2.bb | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/tftpy_0.8.2.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/tftpy_0.8.2.bb b/meta-python/recipes-devtools/python/tftpy_0.8.2.bb
new file mode 100644
index 000000000..c1b3234f7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/tftpy_0.8.2.bb
@@ -0,0 +1,13 @@ 
+SUMMARY = "Tftpy is a TFTP library for the Python programming language. It includes client and server classes, with sample implementations."
+DESCRIPTION = "Tftpy is a TFTP library for the Python programming language. It \
+includes client and server classes, with sample implementations. Hooks are \
+included for easy inclusion in a UI for populating progress indicators. It \
+supports RFCs 1350, 2347, 2348 and the tsize option from RFC 2349."
+
+HOMEPAGE = "https://github.com/msoulier/tftpy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=22770e72ae03c61f5bcc4e333b61368d"
+
+SRC_URI[sha256sum] = "e1d1a680efd88eba176b351175844253067392a9b0f8b81588e3ff2b9e7bbb5b"
+
+inherit pypi setuptools3