diff mbox series

boost: upgrade 1.80.0 -> 1.81.0

Message ID 1671591551-12455-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 16d33730845895dac7e6fa1e03778ca49b37adce
Headers show
Series boost: upgrade 1.80.0 -> 1.81.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 21, 2022, 2:59 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
removed since it's included in 1.81.0

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{boost-1.80.0.inc => boost-1.81.0.inc}    |  2 +-
 ...y-binary_function-base-classes-are-d.patch | 34 -------------------
 .../{boost_1.80.0.bb => boost_1.81.0.bb}      |  1 -
 3 files changed, 1 insertion(+), 36 deletions(-)
 rename meta/recipes-support/boost/{boost-1.80.0.inc => boost-1.81.0.inc} (90%)
 delete mode 100644 meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
 rename meta/recipes-support/boost/{boost_1.80.0.bb => boost_1.81.0.bb} (75%)

Comments

Christian Eggers Jan. 4, 2023, 10:43 a.m. UTC | #1
On Wednesday, 21 December 2022, 03:59:07 CET, wangmy@fujitsu.com wrote:
> From: Wang Mingyu <wangmy@fujitsu.com>
> 
> 0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
> removed since it's included in 1.81.0
> 
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../{boost-1.80.0.inc => boost-1.81.0.inc}    |  2 +-
>  ...y-binary_function-base-classes-are-d.patch | 34 -------------------
>  .../{boost_1.80.0.bb => boost_1.81.0.bb}      |  1 -
>  3 files changed, 1 insertion(+), 36 deletions(-)
>  rename meta/recipes-support/boost/{boost-1.80.0.inc => boost-1.81.0.inc} (90%)
>  delete mode 100644 meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
>  rename meta/recipes-support/boost/{boost_1.80.0.bb => boost_1.81.0.bb} (75%)
> 
> diff --git a/meta/recipes-support/boost/boost-1.80.0.inc b/meta/recipes-support/boost/boost-1.81.0.inc
> similarity index 90%
> rename from meta/recipes-support/boost/boost-1.80.0.inc
> rename to meta/recipes-support/boost/boost-1.81.0.inc
> index 3ee82eb9b2..291796c736 100644
> --- a/meta/recipes-support/boost/boost-1.80.0.inc
> +++ b/meta/recipes-support/boost/boost-1.81.0.inc
> @@ -12,7 +12,7 @@ BOOST_MAJ = "${@"_".join(d.getVar("PV").split(".")[0:2])}"
>  BOOST_P = "boost_${BOOST_VER}"
>  
>  SRC_URI = "https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/${BOOST_P}.tar.bz2"
> -SRC_URI[sha256sum] = "1e19565d82e43bc59209a168f5ac899d3ba471d55c7610c677d4ccf2c9c500c0"
> +SRC_URI[sha256sum] = "71feeed900fbccca04a3b4f2f84a7c217186f28a940ed8b7ed4725986baf99fa"
>  
>  UPSTREAM_CHECK_URI = "http://www.boost.org/users/download/"
>  UPSTREAM_CHECK_REGEX = "release/(?P<pver>.*)/source/"
> diff --git a/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch b/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
> deleted file mode 100644
> index 49603348ee..0000000000
> --- a/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
> +++ /dev/null
> @@ -1,34 +0,0 @@
> -From f9b55f5a1fab85bf73c95e6372779d6f50f75e84 Mon Sep 17 00:00:00 2001
> -From: jzmaddock <john@johnmaddock.co.uk>
> -Date: Mon, 11 Jul 2022 18:26:07 +0100
> -Subject: [PATCH] The std lib unary/binary_function base classes are
> - deprecated/removed from libcpp15. Fixes
> - https://github.com/boostorg/container_hash/issues/24.
> -
> -Upstream-Status: Backport [https://github.com/boostorg/config/pull/440/commits/f0af4a9184457939b89110795ae2d293582c5f66]
> -Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ----
> - boost/config/stdlib/libcpp.hpp | 9 +++++++++
> - 1 file changed, 9 insertions(+)
> -
> -diff --git a/boost/config/stdlib/libcpp.hpp b/boost/config/stdlib/libcpp.hpp
> -index bc8536ead..0e9f2445e 100644
> ---- a/boost/config/stdlib/libcpp.hpp
> -+++ b/boost/config/stdlib/libcpp.hpp
> -@@ -168,4 +168,13 @@
> - #  define BOOST_NO_CXX14_HDR_SHARED_MUTEX
> - #endif
> - 
> -+#if _LIBCPP_VERSION >= 15000
> -+//
> -+// Unary function is now deprecated in C++11 and later:
> -+//
> -+#if __cplusplus >= 201103L
> -+#define BOOST_NO_CXX98_FUNCTION_BASE
> -+#endif
> -+#endif
> -+
> - //  --- end ---
> --- 
> -2.37.2
> -
> diff --git a/meta/recipes-support/boost/boost_1.80.0.bb b/meta/recipes-support/boost/boost_1.81.0.bb
> similarity index 75%
> rename from meta/recipes-support/boost/boost_1.80.0.bb
> rename to meta/recipes-support/boost/boost_1.81.0.bb
> index c34ab7d703..4b580d078b 100644
> --- a/meta/recipes-support/boost/boost_1.80.0.bb
> +++ b/meta/recipes-support/boost/boost_1.81.0.bb
> @@ -4,5 +4,4 @@ require boost.inc
>  SRC_URI += "file://boost-math-disable-pch-for-gcc.patch \
>             file://0001-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
>             file://0001-dont-setup-compiler-flags-m32-m64.patch \
> -           file://0001-The-std-lib-unary-binary_function-base-classes-are-d.patch \
>             "
> 

There is a new library (boost-url) in boost-1.81.0. So "url" should be added to BOOST_LIBS.
Unfortunately this causes a conflict (sorry, I don't remember which type) with the standalone
boost-url recipe in meta-openembedded (that recipe should be obsolete now).

What is the correct procedure in this case? I guess that it's not possible to atomically remove
the boost-url recipe from meta-openembedded and add "url" to BOOST_LIBS.

regards
Christian
Alexander Kanavin Jan. 4, 2023, 11:03 a.m. UTC | #2
You should send respective patches to both mailing lists at the same
time, noting that one is dependent on the other.

Alex

On Wed, 4 Jan 2023 at 11:44, Christian Eggers <ceggers@arri.de> wrote:
>
> On Wednesday, 21 December 2022, 03:59:07 CET, wangmy@fujitsu.com wrote:
> > From: Wang Mingyu <wangmy@fujitsu.com>
> >
> > 0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
> > removed since it's included in 1.81.0
> >
> > Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> > ---
> >  .../{boost-1.80.0.inc => boost-1.81.0.inc}    |  2 +-
> >  ...y-binary_function-base-classes-are-d.patch | 34 -------------------
> >  .../{boost_1.80.0.bb => boost_1.81.0.bb}      |  1 -
> >  3 files changed, 1 insertion(+), 36 deletions(-)
> >  rename meta/recipes-support/boost/{boost-1.80.0.inc => boost-1.81.0.inc} (90%)
> >  delete mode 100644 meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
> >  rename meta/recipes-support/boost/{boost_1.80.0.bb => boost_1.81.0.bb} (75%)
> >
> > diff --git a/meta/recipes-support/boost/boost-1.80.0.inc b/meta/recipes-support/boost/boost-1.81.0.inc
> > similarity index 90%
> > rename from meta/recipes-support/boost/boost-1.80.0.inc
> > rename to meta/recipes-support/boost/boost-1.81.0.inc
> > index 3ee82eb9b2..291796c736 100644
> > --- a/meta/recipes-support/boost/boost-1.80.0.inc
> > +++ b/meta/recipes-support/boost/boost-1.81.0.inc
> > @@ -12,7 +12,7 @@ BOOST_MAJ = "${@"_".join(d.getVar("PV").split(".")[0:2])}"
> >  BOOST_P = "boost_${BOOST_VER}"
> >
> >  SRC_URI = "https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/${BOOST_P}.tar.bz2"
> > -SRC_URI[sha256sum] = "1e19565d82e43bc59209a168f5ac899d3ba471d55c7610c677d4ccf2c9c500c0"
> > +SRC_URI[sha256sum] = "71feeed900fbccca04a3b4f2f84a7c217186f28a940ed8b7ed4725986baf99fa"
> >
> >  UPSTREAM_CHECK_URI = "http://www.boost.org/users/download/"
> >  UPSTREAM_CHECK_REGEX = "release/(?P<pver>.*)/source/"
> > diff --git a/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch b/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
> > deleted file mode 100644
> > index 49603348ee..0000000000
> > --- a/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
> > +++ /dev/null
> > @@ -1,34 +0,0 @@
> > -From f9b55f5a1fab85bf73c95e6372779d6f50f75e84 Mon Sep 17 00:00:00 2001
> > -From: jzmaddock <john@johnmaddock.co.uk>
> > -Date: Mon, 11 Jul 2022 18:26:07 +0100
> > -Subject: [PATCH] The std lib unary/binary_function base classes are
> > - deprecated/removed from libcpp15. Fixes
> > - https://github.com/boostorg/container_hash/issues/24.
> > -
> > -Upstream-Status: Backport [https://github.com/boostorg/config/pull/440/commits/f0af4a9184457939b89110795ae2d293582c5f66]
> > -Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ----
> > - boost/config/stdlib/libcpp.hpp | 9 +++++++++
> > - 1 file changed, 9 insertions(+)
> > -
> > -diff --git a/boost/config/stdlib/libcpp.hpp b/boost/config/stdlib/libcpp.hpp
> > -index bc8536ead..0e9f2445e 100644
> > ---- a/boost/config/stdlib/libcpp.hpp
> > -+++ b/boost/config/stdlib/libcpp.hpp
> > -@@ -168,4 +168,13 @@
> > - #  define BOOST_NO_CXX14_HDR_SHARED_MUTEX
> > - #endif
> > -
> > -+#if _LIBCPP_VERSION >= 15000
> > -+//
> > -+// Unary function is now deprecated in C++11 and later:
> > -+//
> > -+#if __cplusplus >= 201103L
> > -+#define BOOST_NO_CXX98_FUNCTION_BASE
> > -+#endif
> > -+#endif
> > -+
> > - //  --- end ---
> > ---
> > -2.37.2
> > -
> > diff --git a/meta/recipes-support/boost/boost_1.80.0.bb b/meta/recipes-support/boost/boost_1.81.0.bb
> > similarity index 75%
> > rename from meta/recipes-support/boost/boost_1.80.0.bb
> > rename to meta/recipes-support/boost/boost_1.81.0.bb
> > index c34ab7d703..4b580d078b 100644
> > --- a/meta/recipes-support/boost/boost_1.80.0.bb
> > +++ b/meta/recipes-support/boost/boost_1.81.0.bb
> > @@ -4,5 +4,4 @@ require boost.inc
> >  SRC_URI += "file://boost-math-disable-pch-for-gcc.patch \
> >             file://0001-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
> >             file://0001-dont-setup-compiler-flags-m32-m64.patch \
> > -           file://0001-The-std-lib-unary-binary_function-base-classes-are-d.patch \
> >             "
> >
>
> There is a new library (boost-url) in boost-1.81.0. So "url" should be added to BOOST_LIBS.
> Unfortunately this causes a conflict (sorry, I don't remember which type) with the standalone
> boost-url recipe in meta-openembedded (that recipe should be obsolete now).
>
> What is the correct procedure in this case? I guess that it's not possible to atomically remove
> the boost-url recipe from meta-openembedded and add "url" to BOOST_LIBS.
>
> regards
> Christian
>
>
>
diff mbox series

Patch

diff --git a/meta/recipes-support/boost/boost-1.80.0.inc b/meta/recipes-support/boost/boost-1.81.0.inc
similarity index 90%
rename from meta/recipes-support/boost/boost-1.80.0.inc
rename to meta/recipes-support/boost/boost-1.81.0.inc
index 3ee82eb9b2..291796c736 100644
--- a/meta/recipes-support/boost/boost-1.80.0.inc
+++ b/meta/recipes-support/boost/boost-1.81.0.inc
@@ -12,7 +12,7 @@  BOOST_MAJ = "${@"_".join(d.getVar("PV").split(".")[0:2])}"
 BOOST_P = "boost_${BOOST_VER}"
 
 SRC_URI = "https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/${BOOST_P}.tar.bz2"
-SRC_URI[sha256sum] = "1e19565d82e43bc59209a168f5ac899d3ba471d55c7610c677d4ccf2c9c500c0"
+SRC_URI[sha256sum] = "71feeed900fbccca04a3b4f2f84a7c217186f28a940ed8b7ed4725986baf99fa"
 
 UPSTREAM_CHECK_URI = "http://www.boost.org/users/download/"
 UPSTREAM_CHECK_REGEX = "release/(?P<pver>.*)/source/"
diff --git a/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch b/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
deleted file mode 100644
index 49603348ee..0000000000
--- a/meta/recipes-support/boost/boost/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch
+++ /dev/null
@@ -1,34 +0,0 @@ 
-From f9b55f5a1fab85bf73c95e6372779d6f50f75e84 Mon Sep 17 00:00:00 2001
-From: jzmaddock <john@johnmaddock.co.uk>
-Date: Mon, 11 Jul 2022 18:26:07 +0100
-Subject: [PATCH] The std lib unary/binary_function base classes are
- deprecated/removed from libcpp15. Fixes
- https://github.com/boostorg/container_hash/issues/24.
-
-Upstream-Status: Backport [https://github.com/boostorg/config/pull/440/commits/f0af4a9184457939b89110795ae2d293582c5f66]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- boost/config/stdlib/libcpp.hpp | 9 +++++++++
- 1 file changed, 9 insertions(+)
-
-diff --git a/boost/config/stdlib/libcpp.hpp b/boost/config/stdlib/libcpp.hpp
-index bc8536ead..0e9f2445e 100644
---- a/boost/config/stdlib/libcpp.hpp
-+++ b/boost/config/stdlib/libcpp.hpp
-@@ -168,4 +168,13 @@
- #  define BOOST_NO_CXX14_HDR_SHARED_MUTEX
- #endif
- 
-+#if _LIBCPP_VERSION >= 15000
-+//
-+// Unary function is now deprecated in C++11 and later:
-+//
-+#if __cplusplus >= 201103L
-+#define BOOST_NO_CXX98_FUNCTION_BASE
-+#endif
-+#endif
-+
- //  --- end ---
--- 
-2.37.2
-
diff --git a/meta/recipes-support/boost/boost_1.80.0.bb b/meta/recipes-support/boost/boost_1.81.0.bb
similarity index 75%
rename from meta/recipes-support/boost/boost_1.80.0.bb
rename to meta/recipes-support/boost/boost_1.81.0.bb
index c34ab7d703..4b580d078b 100644
--- a/meta/recipes-support/boost/boost_1.80.0.bb
+++ b/meta/recipes-support/boost/boost_1.81.0.bb
@@ -4,5 +4,4 @@  require boost.inc
 SRC_URI += "file://boost-math-disable-pch-for-gcc.patch \
            file://0001-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
            file://0001-dont-setup-compiler-flags-m32-m64.patch \
-           file://0001-The-std-lib-unary-binary_function-base-classes-are-d.patch \
            "