diff mbox series

[dunfell] k3: also inherit kernel-fitimage class for FIT image generation

Message ID 20221213210653.2450345-1-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [dunfell] k3: also inherit kernel-fitimage class for FIT image generation | expand

Commit Message

Denys Dmytriyenko Dec. 13, 2022, 9:06 p.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

In order to support fitImage image type, kernel-fitimage class is needed.

Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
(cherry picked from kirkstone/master commit 48b22e8266ba0358b5b7319faa75ad731a350db7)
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 conf/machine/include/k3.inc | 1 +
 1 file changed, 1 insertion(+)

Comments

Jose Quaresma Dec. 14, 2022, 9:32 a.m. UTC | #1
Hi Denys,

Tested this locally and it fixes the following issue:

| make[1]: *** No rule to make target 'fitImage'.  Stop.
| make: *** [/build/tmp/work-shared/am64xx-evm/kernel-source/Makefile:185:
__sub-make] Error 2
| ERROR: oe_runmake failed
| WARNING: exit code 1 from a shell command.
| ERROR: Execution of
'/build/tmp/work/am64xx_evm-poky-linux/linux-ti-staging/5.10.158+gitAUTOINC+14d010266b-r0b/temp/run.do_compile.2076'
failed with exit code 1
ERROR: Task
(/build/../work/meta-ti/recipes-kernel/linux/linux-ti-staging_5.10.bb:do_compile)
failed with exit code '1'

Tested-by: Jose Quaresma <jose.quaresma@foundries.io>

Denys Dmytriyenko <denis@denix.org> escreveu no dia terça, 13/12/2022 à(s)
21:06:

> From: Denys Dmytriyenko <denys@konsulko.com>
>
> In order to support fitImage image type, kernel-fitimage class is needed.
>
> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> (cherry picked from kirkstone/master commit
> 48b22e8266ba0358b5b7319faa75ad731a350db7)
> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
> ---
>  conf/machine/include/k3.inc | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/conf/machine/include/k3.inc b/conf/machine/include/k3.inc
> index 349f4fda..81139571 100644
> --- a/conf/machine/include/k3.inc
> +++ b/conf/machine/include/k3.inc
> @@ -16,6 +16,7 @@ PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
>
>  KERNEL_IMAGETYPE = "Image"
>  KERNEL_IMAGETYPES = "Image fitImage"
> +KERNEL_CLASSES += "kernel-fitimage"
>
>  UBOOT_ARCH = "arm"
>  UBOOT_ENTRYPOINT = "0x80008000"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#15469):
> https://lists.yoctoproject.org/g/meta-ti/message/15469
> Mute This Topic: https://lists.yoctoproject.org/mt/95653946/5052612
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Jose Quaresma Jan. 4, 2023, 7:26 p.m. UTC | #2
Friendly ping :)

thanks

Jose Quaresma via lists.yoctoproject.org <quaresma.jose=
gmail.com@lists.yoctoproject.org> escreveu no dia quarta, 14/12/2022 à(s)
09:32:

> Hi Denys,
>
> Tested this locally and it fixes the following issue:
>
> | make[1]: *** No rule to make target 'fitImage'.  Stop.
> | make: *** [/build/tmp/work-shared/am64xx-evm/kernel-source/Makefile:185:
> __sub-make] Error 2
> | ERROR: oe_runmake failed
> | WARNING: exit code 1 from a shell command.
> | ERROR: Execution of
> '/build/tmp/work/am64xx_evm-poky-linux/linux-ti-staging/5.10.158+gitAUTOINC+14d010266b-r0b/temp/run.do_compile.2076'
> failed with exit code 1
> ERROR: Task
> (/build/../work/meta-ti/recipes-kernel/linux/linux-ti-staging_5.10.bb:do_compile)
> failed with exit code '1'
>
> Tested-by: Jose Quaresma <jose.quaresma@foundries.io>
>
> Denys Dmytriyenko <denis@denix.org> escreveu no dia terça, 13/12/2022
> à(s) 21:06:
>
>> From: Denys Dmytriyenko <denys@konsulko.com>
>>
>> In order to support fitImage image type, kernel-fitimage class is needed.
>>
>> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
>> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
>> (cherry picked from kirkstone/master commit
>> 48b22e8266ba0358b5b7319faa75ad731a350db7)
>> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
>> ---
>>  conf/machine/include/k3.inc | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/conf/machine/include/k3.inc b/conf/machine/include/k3.inc
>> index 349f4fda..81139571 100644
>> --- a/conf/machine/include/k3.inc
>> +++ b/conf/machine/include/k3.inc
>> @@ -16,6 +16,7 @@ PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
>>
>>  KERNEL_IMAGETYPE = "Image"
>>  KERNEL_IMAGETYPES = "Image fitImage"
>> +KERNEL_CLASSES += "kernel-fitimage"
>>
>>  UBOOT_ARCH = "arm"
>>  UBOOT_ENTRYPOINT = "0x80008000"
>> --
>> 2.25.1
>>
>>
>>
>>
>>
>
> --
> Best regards,
>
> José Quaresma
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#15474):
> https://lists.yoctoproject.org/g/meta-ti/message/15474
> Mute This Topic: https://lists.yoctoproject.org/mt/95653946/5052612
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/conf/machine/include/k3.inc b/conf/machine/include/k3.inc
index 349f4fda..81139571 100644
--- a/conf/machine/include/k3.inc
+++ b/conf/machine/include/k3.inc
@@ -16,6 +16,7 @@  PREFERRED_PROVIDER_u-boot = "u-boot-ti-staging"
 
 KERNEL_IMAGETYPE = "Image"
 KERNEL_IMAGETYPES = "Image fitImage"
+KERNEL_CLASSES += "kernel-fitimage"
 
 UBOOT_ARCH = "arm"
 UBOOT_ENTRYPOINT = "0x80008000"