diff mbox series

[meta-python,v2] python3-rapidjson: add recipe

Message ID 20221213102942.45198-1-roger@norberthealth.com
State Under Review
Headers show
Series [meta-python,v2] python3-rapidjson: add recipe | expand

Commit Message

Roger Knecht Dec. 13, 2022, 10:29 a.m. UTC
Add a recipe for the python bindings of the rapidjson library.

Signed-off-by: Roger Knecht <roger@norberthealth.com>
---
v2:
- Removed Git submodule fetch
- Use rapidjson library from meta-oe recipe instead of Git submodule

 .../python/python3-rapidjson_1.9.bb           | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
new file mode 100644
index 000000000..8b50aabb7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
@@ -0,0 +1,22 @@ 
+SUMMARY = "Python wrapper around rapidjson"
+HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
+
+SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master"
+SRCREV = "8f4ab8e197ca30c03726b675ae7cce6ac9d6622e"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
+
+DEPENDS += " \
+    rapidjson \
+"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-core \
+"