diff mbox series

[meta-python] python3-rapidjson: add recipe

Message ID 20221212175836.13560-1-roger@norberthealth.com
State Under Review
Headers show
Series [meta-python] python3-rapidjson: add recipe | expand

Commit Message

Roger Knecht Dec. 12, 2022, 5:58 p.m. UTC
Add a recipe for the python bindings of the rapidjson library.

Signed-off-by: Roger Knecht <roger@norberthealth.com>
---
 .../python/python3-rapidjson_1.9.bb             | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb

Comments

Fabio Estevam Dec. 12, 2022, 10:38 p.m. UTC | #1
On Mon, Dec 12, 2022 at 2:59 PM Roger Knecht <roger@norberthealth.com> wrote:
>
> Add a recipe for the python bindings of the rapidjson library.
>
> Signed-off-by: Roger Knecht <roger@norberthealth.com>
> ---
>  .../python/python3-rapidjson_1.9.bb             | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
> new file mode 100644
> index 000000000..ebf053396
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Python wrapper around rapidjson"
> +HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
> +
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"

It looks like the license information is not complete, this project
uses rapidjson as a submodule,
which has the following licensing information:

https://github.com/Tencent/rapidjson/blob/232389d4f1012dddec4ef84861face2d2ba85709/license.txt
Roger Knecht Dec. 13, 2022, 8:44 a.m. UTC | #2
Hi Fabio,

Thanks for the review.

That's a good point. I overlooked that the python module is building
the rapidjson library from the submodule.
I will remove the submodule and try to make the build work with the
rapidjson library from meta-oe.
This way the python3-rapidjson has only an MIT license and the rest of
files are handled by the rapidjson recipe.

Roger

On Mon, Dec 12, 2022 at 11:39 PM Fabio Estevam <festevam@gmail.com> wrote:
>
> On Mon, Dec 12, 2022 at 2:59 PM Roger Knecht <roger@norberthealth.com> wrote:
> >
> > Add a recipe for the python bindings of the rapidjson library.
> >
> > Signed-off-by: Roger Knecht <roger@norberthealth.com>
> > ---
> >  .../python/python3-rapidjson_1.9.bb             | 17 +++++++++++++++++
> >  1 file changed, 17 insertions(+)
> >  create mode 100644 meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
> > new file mode 100644
> > index 000000000..ebf053396
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
> > @@ -0,0 +1,17 @@
> > +SUMMARY = "Python wrapper around rapidjson"
> > +HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
> > +
> > +LICENSE = "MIT"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
>
> It looks like the license information is not complete, this project
> uses rapidjson as a submodule,
> which has the following licensing information:
>
> https://github.com/Tencent/rapidjson/blob/232389d4f1012dddec4ef84861face2d2ba85709/license.txt
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
new file mode 100644
index 000000000..ebf053396
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Python wrapper around rapidjson"
+HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
+
+SRC_URI = "gitsm://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master"
+SRCREV = "8f4ab8e197ca30c03726b675ae7cce6ac9d6622e"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-core \
+    rapidjson \
+"