Patchwork [2/2] qemu: enabling the alsa driver needs alsa in DEPENDS, add it

login
register
mail settings
Submitter Koen Kooi
Date March 21, 2011, 9:38 a.m.
Message ID <1300700320-25880-2-git-send-email-koen@dominion.thruhere.net>
Download mbox | patch
Permalink /patch/1647/
State New, archived
Headers show

Comments

Koen Kooi - March 21, 2011, 9:38 a.m.
From: Koen Kooi <koen@dominion.thruhere.net>

This fixes:

| + /OE/tentacle/build/tmp-angstrom_2010_x/work/x86_64-linux/qemu-native-0.13.0-r1/qemu-0.13.0/configure --prefix=/OE/tentacle/build/tmp-angstrom_2010_x/sysroots/x86_64-linux/usr --target-list=arm-linux-user,arm-softmmu,i386-linux-user,i386-softmmu,x86_64-linux-user,x86_64-softmmu,mips-linux-user,mips-softmmu,ppc-linux-user,ppc-softmmu,mipsel-linux-user --disable-werror --disable-vnc-tls --enable-kvm --audio-drv-list=oss,alsa --audio-card-list=ac97,es1370
|
| Error: alsa check failed
| Make sure to have the alsa libs and headers installed.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
---
 meta/recipes-devtools/qemu/qemu.inc |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Patch

diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index 2c6b114..f41b49c 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -1,7 +1,7 @@ 
 DESCRIPTION = "open source processor emulator"
 HOMEPAGE = "http://qemu.org"
 LICENSE = "GPLv2 & LGPLv2.1"
-DEPENDS = "zlib"
+DEPENDS = "zlib alsa-lib"
 
 EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-linux-user,i386-softmmu,x86_64-linux-user,x86_64-softmmu,mips-linux-user,mips-softmmu,ppc-linux-user,ppc-softmmu,mipsel-linux-user --disable-werror --disable-vnc-tls --enable-kvm --audio-drv-list=oss,alsa --audio-card-list=ac97,es1370"
 #EXTRA_OECONF += "--disable-sdl"