diff mbox series

[meta-python,v2] tuna: add recipe

Message ID 20221206103444.255618-2-erwann.roussy@savoirfairelinux.com
State Under Review
Headers show
Series [meta-python,v2] tuna: add recipe | expand

Commit Message

Erwann Roussy Dec. 6, 2022, 10:34 a.m. UTC
Tuna is a cui/gui tool for tuning of running processes.
It is useful to see and changed irq affinity on an embedded board.

The chosen revision of tuna is the last commit to this day and not the
last release. This is due to the python3-ethtool module which was
required in the last release but isn't anymore. Tuna now has a built-in
module instead.

Despite tuna's homepage's dependencies section, python3-inet_diag isn't
required anymore.

Signed-off-by: Erwann Roussy <erwann.roussy@savoirfairelinux.com>
---
 meta-python/recipes-extended/tuna/tuna_git.bb | 24 +++++++++++++++++++
 1 file changed, 24 insertions(+)
 create mode 100644 meta-python/recipes-extended/tuna/tuna_git.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-extended/tuna/tuna_git.bb b/meta-python/recipes-extended/tuna/tuna_git.bb
new file mode 100644
index 000000000..a49341240
--- /dev/null
+++ b/meta-python/recipes-extended/tuna/tuna_git.bb
@@ -0,0 +1,24 @@ 
+SUMMARY = "cui/gui tool for tuning of running processes"
+HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Tuna"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/tuna/tuna.git;branch=main"
+
+SRCREV = "0681906e75e1c8166126bbfc2f3055e7507bfcb5"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS:${PN} += " \
+    python3-io \
+    python3-linux-procfs \
+    python3-logging \
+    python3-six \
+    "
+
+inherit setuptools3
+
+do_install:append() {
+    install -m 0755 -d ${D}${bindir}
+    install -m 0755 ${S}/tuna-cmd.py ${D}${bindir}/tuna
+}