diff mbox series

[meta-gnome,06/10] rest: Re-add 0.8.1

Message ID 20221130071913.1805812-6-raj.khem@gmail.com
State New
Headers show
Series [meta-filesystem,01/10] aufs-util: Fix build with large file support enabled systems | expand

Commit Message

Khem Raj Nov. 30, 2022, 7:19 a.m. UTC
Its needed by gfbgraph

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-gnome/rest/librest_0.8.1.bb       | 35 +++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 meta-gnome/recipes-gnome/rest/librest_0.8.1.bb
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb b/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb
new file mode 100644
index 0000000000..23849783cc
--- /dev/null
+++ b/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb
@@ -0,0 +1,35 @@ 
+SUMMARY = "library to access web services that claim to be "RESTful""
+HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = " \
+    gi-docgen \
+    gi-docgen-native \
+    glib-2.0 \
+    glib-2.0-native \
+    json-glib \
+    libsoup-2.4 \
+    libxml2-native \
+"
+
+inherit gnomebase gobject-introspection vala pkgconfig
+
+GNOMEBN = "rest"
+
+SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9"
+
+S = "${WORKDIR}/${GNOMEBN}-${PV}"
+# * gnome environment requires libsoup build with in gnome PACKAGECONFIG
+# * libsoup-gnome support was removed upstream three years ago [1]
+# [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720
+EXTRA_OECONF = "--without-gnome"
+
+do_configure:prepend() {
+    # rest expects introspection.m4 at custom location (see aclocal.m4).
+    cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
+}
+
+do_compile:prepend() {
+    export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
+}