diff mbox series

[meta-oe,05/10] satyr: Inherit python3targetconfig

Message ID 20221130071913.1805812-5-raj.khem@gmail.com
State New
Headers show
Series [meta-filesystem,01/10] aufs-util: Fix build with large file support enabled systems | expand

Commit Message

Khem Raj Nov. 30, 2022, 7:19 a.m. UTC
It uses python3-config during build to grok the python specific
includedirs, therefore its important to ensure that target specific
python3-config is used, otherwise currently it defaults to native
python3-config which ends up adding native python3 include paths
which might work out ok but is exposed when target is 32bit + lfs
enabled, the headers don't match between native and target python

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-support/satyr/satyr_0.40.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/satyr/satyr_0.40.bb b/meta-oe/recipes-support/satyr/satyr_0.40.bb
index 5b44618b72..1ce28f1f04 100644
--- a/meta-oe/recipes-support/satyr/satyr_0.40.bb
+++ b/meta-oe/recipes-support/satyr/satyr_0.40.bb
@@ -5,7 +5,7 @@  space, Python, and Java programs"
 HOMEPAGE = "https://github.com/abrt/satyr"
 LICENSE = "GPL-2.0-only"
 
-inherit autotools-brokensep python3native pkgconfig
+inherit autotools-brokensep python3native python3targetconfig pkgconfig
 
 SRC_URI = "git://github.com/abrt/satyr.git;branch=master;protocol=https \
            file://0002-fix-compile-failure-against-musl-C-library.patch \