diff mbox series

[meta-python,1/2] python3-binwalk: add recipe for version 2.3.3

Message ID 20221125114411.128952-1-tomasz.zyjewski@3mdeb.com
State Under Review
Headers show
Series [meta-python,1/2] python3-binwalk: add recipe for version 2.3.3 | expand

Commit Message

Tomasz Żyjewski Nov. 25, 2022, 11:44 a.m. UTC
Install binwalk utility

Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
---
 .../python/python3-binwalk_2.3.3.bb             | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb

Comments

Tim Orling Nov. 26, 2022, 11:18 p.m. UTC | #1
On Fri, Nov 25, 2022 at 3:44 AM tomzy <tomasz.zyjewski@3mdeb.com> wrote:

> Install binwalk utility
>
> Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
> ---
>  .../python/python3-binwalk_2.3.3.bb             | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/
> python3-binwalk_2.3.3.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
> b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
> new file mode 100644
> index 000000000000..362efa275148
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Firmware analysis tool"
> +DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a
> fast, \
> +easy to use tool for analyzing, reverse engineering, and extracting
> firmware \
> +images."
> +HOMEPAGE = "https://github.com/ReFirmLabs/binwalk"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
> +
> +SRC_URI = "git://
> github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
> +


Thank you for fetching the git repo which is much newer (and with better
security apparently) than the pypi version.


> +SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit setuptools3
> +
> +RDEPENDS:${PN} += "python3-core"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99728):
> https://lists.openembedded.org/g/openembedded-devel/message/99728
> Mute This Topic: https://lists.openembedded.org/mt/95252446/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Tomasz Żyjewski Nov. 30, 2022, 7:28 a.m. UTC | #2
> 
> On Fri, Nov 25, 2022 at 3:44 AM tomzy < tomasz.zyjewski@... > wrote:
> 

> 
> Install binwalk utility
> 
> Signed-off-by: Tomasz Żyjewski < tomasz.zyjewski@... >
> ---
> .../python/ python3-binwalk_2.3.3.bb ( http://python3-binwalk_2.3.3.bb ) |
> 17 +++++++++++++++++
> 1 file changed, 17 insertions(+)
> create mode 100644 meta-python/recipes-devtools/python/ python3-binwalk_2.3.3.bb
> ( http://python3-binwalk_2.3.3.bb )
> 
> diff --git a/meta-python/recipes-devtools/python/ python3-binwalk_2.3.3.bb
> ( http://python3-binwalk_2.3.3.bb ) b/meta-python/recipes-devtools/python/
> python3-binwalk_2.3.3.bb ( http://python3-binwalk_2.3.3.bb )
> new file mode 100644
> index 000000000000..362efa275148
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/ python3-binwalk_2.3.3.bb (
> http://python3-binwalk_2.3.3.bb )
> @@ -0,0 +1,17 @@
> +SUMMARY = "Firmware analysis tool"
> +DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a
> fast, \
> +easy to use tool for analyzing, reverse engineering, and extracting
> firmware \
> +images."
> +HOMEPAGE = " https://github.com/ReFirmLabs/binwalk "
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
> +
> +SRC_URI = "git:// github.com/ReFirmLabs/binwalk;protocol=https;branch=master
> ( http://github.com/ReFirmLabs/binwalk;protocol=https;branch=master ) "
> +

> 
> 
> Thank you for fetching the git repo which is much newer (and with better
> security apparently) than the pypi version.
> 

I will do the same with the python3-uefi-firmware recipe

> 
> 
> 
> +SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd" + +S =
> "${WORKDIR}/git" + +inherit setuptools3 + +RDEPENDS:${PN} +=
> "python3-core" -- 2.25.1
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
new file mode 100644
index 000000000000..362efa275148
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Firmware analysis tool"
+DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a fast, \
+easy to use tool for analyzing, reverse engineering, and extracting firmware \
+images."
+HOMEPAGE = "https://github.com/ReFirmLabs/binwalk"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
+
+SRC_URI = "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
+
+SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "python3-core"