diff mbox series

kbd: DEPEND on bison-native and don't build tests

Message ID 20221124165206.1020295-1-olani@axis.com
State New
Headers show
Series kbd: DEPEND on bison-native and don't build tests | expand

Commit Message

Ola x Nilsson Nov. 24, 2022, 4:52 p.m. UTC
bison-native is required if any .y-file is changed, by patch or in
devtool.  Otherwise the build will fail with

/bin/bash ..../config/ylwrap ..../src/libkeymap/parser.y y.tab.c parser.c y.tab.h `echo parser.c | sed -e s/cc$/hh/ -e s/cpp$/hpp/ -e s/cxx$/hxx/ -e s/c++$/h++/ -e s/c$/h/` y.output parser.output -- yacc
..../kbd/config/ylwrap: line 175: yacc: command not found

All c-files generated from y-files are included in the distribution
tarball, which is why bison has not been needed so far.

Add --disable-tests to EXTRA_OECONF as the tests are not usable in
ptest - they can only run in-situ - and fails when building with
-D_TIME_BITS=64 -D_FILE_OFFSET_BITS=64.

Signed-off-by: Ola x Nilsson <olani@axis.com>
---
 meta/recipes-core/kbd/kbd_2.5.1.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Richard Purdie Nov. 24, 2022, 9 p.m. UTC | #1
On Thu, 2022-11-24 at 17:52 +0100, Ola x Nilsson wrote:
> bison-native is required if any .y-file is changed, by patch or in
> devtool.  Otherwise the build will fail with

The key point is that we don't patch any .y file out the box. I
therefore don't want to add this dependency.

If you do start adding patches you can easily add the dependency too?

Cheers,

Richard
Ola x Nilsson Nov. 25, 2022, 7:41 a.m. UTC | #2
On Thu, Nov 24 2022, Richard Purdie wrote:

> On Thu, 2022-11-24 at 17:52 +0100, Ola x Nilsson wrote:
>> bison-native is required if any .y-file is changed, by patch or in
>> devtool.  Otherwise the build will fail with
>
> The key point is that we don't patch any .y file out the box. I
> therefore don't want to add this dependency.

I get that.  I'll send a v2. 

> If you do start adding patches you can easily add the dependency too?

Of course.
diff mbox series

Patch

diff --git a/meta/recipes-core/kbd/kbd_2.5.1.bb b/meta/recipes-core/kbd/kbd_2.5.1.bb
index aa3ab6e121..75b3c2765a 100644
--- a/meta/recipes-core/kbd/kbd_2.5.1.bb
+++ b/meta/recipes-core/kbd/kbd_2.5.1.bb
@@ -7,7 +7,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
 inherit autotools gettext pkgconfig
 
-DEPENDS += "flex-native"
+DEPENDS += "bison-native flex-native"
 
 RREPLACES:${PN} = "console-tools"
 RPROVIDES:${PN} = "console-tools"
@@ -18,6 +18,7 @@  SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
 
 SRC_URI[sha256sum] = "ccdf452387a6380973d2927363e9cbb939fa2068915a6f937ff9d24522024683"
 
+EXTRA_OECONF = "--disable-tests"
 PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
                   "