diff mbox series

kbd: DEPEND on bison-native and don't build tests

Message ID 20221122160039.3693939-1-olani@axis.com
State New
Headers show
Series kbd: DEPEND on bison-native and don't build tests | expand

Commit Message

Ola x Nilsson Nov. 22, 2022, 4 p.m. UTC
bison-native is required if any .y-file is changed.

Add --disable-tests to EXTRA_OECONF as the tests are not usable in
ptest - they can only run in-situ - and fails when building with
-D_TIME_BITS=64 -D_FILE_OFFSET_BITS=64.

Signed-off-by: Ola x Nilsson <olani@axis.com>
---
 meta/recipes-core/kbd/kbd_2.5.1.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Khem Raj Nov. 23, 2022, 5:03 p.m. UTC | #1
please send this patch to oe-core mailing list as thats where the
patch belongs to

On Tue, Nov 22, 2022 at 8:00 AM Ola x Nilsson <olani@axis.com> wrote:
>
> bison-native is required if any .y-file is changed.
>
> Add --disable-tests to EXTRA_OECONF as the tests are not usable in
> ptest - they can only run in-situ - and fails when building with
> -D_TIME_BITS=64 -D_FILE_OFFSET_BITS=64.
>
> Signed-off-by: Ola x Nilsson <olani@axis.com>
> ---
>  meta/recipes-core/kbd/kbd_2.5.1.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/kbd/kbd_2.5.1.bb b/meta/recipes-core/kbd/kbd_2.5.1.bb
> index aa3ab6e121..75b3c2765a 100644
> --- a/meta/recipes-core/kbd/kbd_2.5.1.bb
> +++ b/meta/recipes-core/kbd/kbd_2.5.1.bb
> @@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
>
>  inherit autotools gettext pkgconfig
>
> -DEPENDS += "flex-native"
> +DEPENDS += "bison-native flex-native"
>
>  RREPLACES:${PN} = "console-tools"
>  RPROVIDES:${PN} = "console-tools"
> @@ -18,6 +18,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
>
>  SRC_URI[sha256sum] = "ccdf452387a6380973d2927363e9cbb939fa2068915a6f937ff9d24522024683"
>
> +EXTRA_OECONF = "--disable-tests"
>  PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
>                    "
>
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99688): https://lists.openembedded.org/g/openembedded-devel/message/99688
> Mute This Topic: https://lists.openembedded.org/mt/95199342/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie Nov. 23, 2022, 9:53 p.m. UTC | #2
On Tue, 2022-11-22 at 17:00 +0100, Ola x Nilsson wrote:
> bison-native is required if any .y-file is changed.
> 
> Add --disable-tests to EXTRA_OECONF as the tests are not usable in
> ptest - they can only run in-situ - and fails when building with
> -D_TIME_BITS=64 -D_FILE_OFFSET_BITS=64.
> 
> Signed-off-by: Ola x Nilsson <olani@axis.com>
> ---
>  meta/recipes-core/kbd/kbd_2.5.1.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-core/kbd/kbd_2.5.1.bb b/meta/recipes-core/kbd/kbd_2.5.1.bb
> index aa3ab6e121..75b3c2765a 100644
> --- a/meta/recipes-core/kbd/kbd_2.5.1.bb
> +++ b/meta/recipes-core/kbd/kbd_2.5.1.bb
> @@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
>  
>  inherit autotools gettext pkgconfig
>  
> -DEPENDS += "flex-native"
> +DEPENDS += "bison-native flex-native"
>  
>  RREPLACES:${PN} = "console-tools"
>  RPROVIDES:${PN} = "console-tools"
> @@ -18,6 +18,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
>  
>  SRC_URI[sha256sum] = "ccdf452387a6380973d2927363e9cbb939fa2068915a6f937ff9d24522024683"
>  
> +EXTRA_OECONF = "--disable-tests"
>  PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
>                    "

This needs to go to the other list. I'd also want to understand why we
don't normally run into any problems despite the missing dependency?
That needs to be explained in the commit message.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-core/kbd/kbd_2.5.1.bb b/meta/recipes-core/kbd/kbd_2.5.1.bb
index aa3ab6e121..75b3c2765a 100644
--- a/meta/recipes-core/kbd/kbd_2.5.1.bb
+++ b/meta/recipes-core/kbd/kbd_2.5.1.bb
@@ -7,7 +7,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
 inherit autotools gettext pkgconfig
 
-DEPENDS += "flex-native"
+DEPENDS += "bison-native flex-native"
 
 RREPLACES:${PN} = "console-tools"
 RPROVIDES:${PN} = "console-tools"
@@ -18,6 +18,7 @@  SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
 
 SRC_URI[sha256sum] = "ccdf452387a6380973d2927363e9cbb939fa2068915a6f937ff9d24522024683"
 
+EXTRA_OECONF = "--disable-tests"
 PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
                   "