Patchwork [meta-gnome] libnotify: add 0.5.2 and make it the default

login
register
mail settings
Submitter Connor Abbott
Date Nov. 20, 2011, 5:56 p.m.
Message ID <1321811782-7133-1-git-send-email-cwabbott0@gmail.com>
Download mbox | patch
Permalink /patch/15167/
State Rejected
Headers show

Comments

Connor Abbott - Nov. 20, 2011, 5:56 p.m.
Versions of libnotify >= 0.6.0 have API changes that break some gnome recipes.

Signed-off-by: Connor Abbott <cwabbott0@gmail.com>
---
 .../recipes-gnome/libnotify/libnotify_0.5.2.bb     |   10 ++++++++++
 .../recipes-gnome/libnotify/libnotify_0.6.0.bb     |    2 ++
 2 files changed, 12 insertions(+), 0 deletions(-)
 create mode 100644 meta-gnome/recipes-gnome/libnotify/libnotify_0.5.2.bb
Koen Kooi - Nov. 21, 2011, 7:57 a.m.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Op 20-11-11 18:56, Connor Abbott schreef:
> Versions of libnotify >= 0.6.0 have API changes that break some gnome
> recipes.

Which recipes are that? The only API breakage I know of is in libnoty >=
0.7.0, which is why that's called 'libnotify3'


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (Darwin)
Comment: GPGTools - http://gpgtools.org

iEYEARECAAYFAk7KBHAACgkQMkyGM64RGpFcmQCfXeZgqdkn76RQO6fErXYARefD
2zsAnAgBzS2HiSx1RQQ+hvW63Le66qsY
=0+pG
-----END PGP SIGNATURE-----
Connor Abbott - Nov. 29, 2011, 11:13 p.m.
Sorry, I must have had the 0.7.0 headers installed and didn't realize it.
Actually, that's a problem; if you build two different packages, one which
requires libnotify and one which requires libnotify3, then the wrong
headers can get installed in the sysroot because the packages have
different names. Anyways, it appears that 0.5.2 is actually newer than
0.6.0 anyways; I'll update the commit message then.
On Nov 21, 2011 2:58 AM, "Koen Kooi" <koen@dominion.thruhere.net> wrote:
>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Op 20-11-11 18:56, Connor Abbott schreef:
> > Versions of libnotify >= 0.6.0 have API changes that break some gnome
> > recipes.
>
> Which recipes are that? The only API breakage I know of is in libnoty >=
> 0.7.0, which is why that's called 'libnotify3'
>
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (Darwin)
> Comment: GPGTools - http://gpgtools.org
>
> iEYEARECAAYFAk7KBHAACgkQMkyGM64RGpFcmQCfXeZgqdkn76RQO6fErXYARefD
> 2zsAnAgBzS2HiSx1RQQ+hvW63Le66qsY
> =0+pG
> -----END PGP SIGNATURE-----
>
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
Khem Raj - Nov. 30, 2011, 10:53 p.m.
On Tue, Nov 29, 2011 at 3:13 PM, Connor Abbott <cwabbott0@gmail.com> wrote:
> Sorry, I must have had the 0.7.0 headers installed and didn't realize it.
> Actually, that's a problem; if you build two different packages, one which
> requires libnotify and one which requires libnotify3, then the wrong
> headers can get installed in the sysroot because the packages have
> different names. Anyways, it appears that 0.5.2 is actually newer than
> 0.6.0 anyways; I'll update the commit message then.

if they are incompatible and needs to live together then they should
have different install locations
in sysroot for headers and libs e.g. /usr/include/libnotify2 and
/usr/include/libnotify3
Connor Abbott - Dec. 5, 2011, 1:19 a.m.
Well, in this case they don't, everything just intalls to
/usr/include/notify. The reason is that usually, programs using libnotify
hardcode that directory like this:
#include <notify/notify.h>

So it's impossible to install multiple versions at once without breakage at
least without changing the library itself or all its dependencies, as I
discovered.

On Wed, Nov 30, 2011 at 5:53 PM, Khem Raj <raj.khem@gmail.com> wrote:

> On Tue, Nov 29, 2011 at 3:13 PM, Connor Abbott <cwabbott0@gmail.com>
> wrote:
> > Sorry, I must have had the 0.7.0 headers installed and didn't realize it.
> > Actually, that's a problem; if you build two different packages, one
> which
> > requires libnotify and one which requires libnotify3, then the wrong
> > headers can get installed in the sysroot because the packages have
> > different names. Anyways, it appears that 0.5.2 is actually newer than
> > 0.6.0 anyways; I'll update the commit message then.
>
> if they are incompatible and needs to live together then they should
> have different install locations
> in sysroot for headers and libs e.g. /usr/include/libnotify2 and
> /usr/include/libnotify3
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
>

Patch

diff --git a/meta-gnome/recipes-gnome/libnotify/libnotify_0.5.2.bb b/meta-gnome/recipes-gnome/libnotify/libnotify_0.5.2.bb
new file mode 100644
index 0000000..5ce0eb6
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libnotify/libnotify_0.5.2.bb
@@ -0,0 +1,10 @@ 
+DESCRIPTION = "Send desktop notifications to a notification daemon"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
+
+DEPENDS = "dbus gtk+"
+
+inherit gnome
+SRC_URI[archive.md5sum] = "4361058ae4e28a9ffce6764e7d03acd1"
+SRC_URI[archive.sha256sum] = "1f6f1a2d6a0e009997c7ed31f6197f9bf09e9b45fb9cd54acabceea951d99062"
diff --git a/meta-gnome/recipes-gnome/libnotify/libnotify_0.6.0.bb b/meta-gnome/recipes-gnome/libnotify/libnotify_0.6.0.bb
index 45adbd7..e6c4a95 100644
--- a/meta-gnome/recipes-gnome/libnotify/libnotify_0.6.0.bb
+++ b/meta-gnome/recipes-gnome/libnotify/libnotify_0.6.0.bb
@@ -5,6 +5,8 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
 
 DEPENDS = "dbus gtk+"
 
+DEFAULT_PREFERENCE = "-99"
+
 inherit gnome
 SRC_URI[archive.md5sum] = "732c9d2cd5eb6a9069264a319d330516"
 SRC_URI[archive.sha256sum] = "73b16a79bb2fed62dcf146b11c4405776cb96a09dce66379ca541da7dbd64210"