diff mbox series

kbd: package some fonts as restricted

Message ID 20221018001415.76680-1-Randy.MacLeod@windriver.com
State New
Headers show
Series kbd: package some fonts as restricted | expand

Commit Message

Randy MacLeod Oct. 18, 2022, 12:14 a.m. UTC
The distribution terms of the Agafari fonts as described in
data/consolefonts/README.Ethiopic is:

Agafari:
  Donated by the Ethiopian Science and Technology Commission
  <ncic@padis.gn.apc.org> or <ncic@telecom.net.et> and may be redistributed
  for non-commercial use under Unix environments only.

so package them seperately to make it easier for affected users
to avoid installing the fonts.

Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
---
 meta/recipes-core/kbd/kbd_2.5.1.bb | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Ross Burton Oct. 18, 2022, 10:25 a.m. UTC | #1
On 18 Oct 2022, at 01:14, Randy MacLeod via lists.openembedded.org <randy.macleod=windriver.com@lists.openembedded.org> wrote:
> 
> The distribution terms of the Agafari fonts as described in
> data/consolefonts/README.Ethiopic is:
> 
> Agafari:
>  Donated by the Ethiopian Science and Technology Commission
>  <ncic@padis.gn.apc.org> or <ncic@telecom.net.et> and may be redistributed
>  for non-commercial use under Unix environments only.
> 
> so package them seperately to make it easier for affected users
> to avoid installing the fonts.

Looks like you need special per-package LICENSE variables set to people can identify this programatically.

Ross
Randy MacLeod Oct. 20, 2022, 12:45 a.m. UTC | #2
On 2022-10-18 06:25, Ross Burton wrote:
> On 18 Oct 2022, at 01:14, Randy MacLeod via lists.openembedded.org <randy.macleod=windriver.com@lists.openembedded.org> wrote:
>> The distribution terms of the Agafari fonts as described in
>> data/consolefonts/README.Ethiopic is:
>>
>> Agafari:
>>   Donated by the Ethiopian Science and Technology Commission
>>   <ncic@padis.gn.apc.org> or <ncic@telecom.net.et> and may be redistributed
>>   for non-commercial use under Unix environments only.
>>
>> so package them seperately to make it easier for affected users
>> to avoid installing the fonts.
> Looks like you need special per-package LICENSE variables set to people can identify this programatically.

Indeed.

v2 will show up at some point, maybe even this week.

../Randy

>
> Ross
Peter Kjellerstedt Oct. 22, 2022, 12:13 a.m. UTC | #3
> -----Original Message-----
> From: openembedded-core@lists.openembedded.org <openembedded-core@lists.openembedded.org> On Behalf Of Randy MacLeod
> Sent: den 18 oktober 2022 02:14
> To: openembedded-core@lists.openembedded.org
> Subject: [OE-core] [PATCH] kbd: package some fonts as restricted
> 
> The distribution terms of the Agafari fonts as described in
> data/consolefonts/README.Ethiopic is:
> 
> Agafari:
>   Donated by the Ethiopian Science and Technology Commission
>   <ncic@padis.gn.apc.org> or <ncic@telecom.net.et> and may be redistributed
>   for non-commercial use under Unix environments only.
> 
> so package them seperately to make it easier for affected users
> to avoid installing the fonts.
> 
> Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
> ---
>  meta/recipes-core/kbd/kbd_2.5.1.bb | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/meta/recipes-core/kbd/kbd_2.5.1.bb b/meta/recipes-core/kbd/kbd_2.5.1.bb
> index aa3ab6e121..8822cdbef4 100644
> --- a/meta/recipes-core/kbd/kbd_2.5.1.bb
> +++ b/meta/recipes-core/kbd/kbd_2.5.1.bb
> @@ -23,9 +23,11 @@ PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES',
> 'pam', d)} \
> 
>  PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
> 
> -PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
> +PACKAGES += "${PN}-consolefonts ${PN}-consolefonts-restricted ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
> 
> -FILES:${PN}-consolefonts = "${datadir}/consolefonts"
> +# Package some fonts as restricted, see README.Ethiopic
> +FILES:${PN}-consolefonts = "${datadir}/consolefonts/[a-zB-Z0-9]*"

Rather than that pretty odd pattern, I recommend to change PACKAGES 
so that ${PN}-consolefonts-restricted comes before "${PN}-consolefonts:

PACKAGES += "${PN}-consolefonts-restricted ${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"

The you can leave FILES:${PN}-consolefonts as it was:

FILES:${PN}-consolefonts = "${datadir}/consolefonts"

> +FILES:${PN}-consolefonts-restricted = "${datadir}/consolefonts/Agafari*"
>  FILES:${PN}-consoletrans = "${datadir}/consoletrans"
>  FILES:${PN}-keymaps = "${datadir}/keymaps"
>  FILES:${PN}-unimaps = "${datadir}/unimaps"
> --
> 2.34.1

//Peter
diff mbox series

Patch

diff --git a/meta/recipes-core/kbd/kbd_2.5.1.bb b/meta/recipes-core/kbd/kbd_2.5.1.bb
index aa3ab6e121..8822cdbef4 100644
--- a/meta/recipes-core/kbd/kbd_2.5.1.bb
+++ b/meta/recipes-core/kbd/kbd_2.5.1.bb
@@ -23,9 +23,11 @@  PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
 
 PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
 
-PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
+PACKAGES += "${PN}-consolefonts ${PN}-consolefonts-restricted ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
 
-FILES:${PN}-consolefonts = "${datadir}/consolefonts"
+# Package some fonts as restricted, see README.Ethiopic
+FILES:${PN}-consolefonts = "${datadir}/consolefonts/[a-zB-Z0-9]*"
+FILES:${PN}-consolefonts-restricted = "${datadir}/consolefonts/Agafari*"
 FILES:${PN}-consoletrans = "${datadir}/consoletrans"
 FILES:${PN}-keymaps = "${datadir}/keymaps"
 FILES:${PN}-unimaps = "${datadir}/unimaps"