diff mbox series

[1/3] zlib: use .gz archive and set a PREMIRROR

Message ID 20221017133211.212616-1-ross.burton@arm.com
State Accepted, archived
Commit c67f71abc61afec701c50e4e7941128eb701fb0a
Headers show
Series [1/3] zlib: use .gz archive and set a PREMIRROR | expand

Commit Message

Ross Burton Oct. 17, 2022, 1:32 p.m. UTC
When a new zlib release is made, the top-level URL is no longer available
and it is only available as a .gz under the /fossils/ directory.

When this happens the source fetch fails and bitbake noisily warns that
it is using the mirrors.  Avoid this by using the .gz tarball and add
the /fossils/ directory to PREMIRRORS so fetches will check there too.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-core/zlib/zlib_1.2.12.bb | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/zlib/zlib_1.2.12.bb b/meta/recipes-core/zlib/zlib_1.2.12.bb
index b999f13530e..2491cb941f5 100644
--- a/meta/recipes-core/zlib/zlib_1.2.12.bb
+++ b/meta/recipes-core/zlib/zlib_1.2.12.bb
@@ -6,7 +6,8 @@  SECTION = "libs"
 LICENSE = "Zlib"
 LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0"
 
-SRC_URI = "https://zlib.net/${BP}.tar.xz \
+# The source tarball needs to be .gz as only the .gz ends up in fossils/
+SRC_URI = "https://zlib.net/${BP}.tar.gz \
            file://cc.patch \
            file://ldflags-tests.patch \
            file://0001-configure-Pass-LDFLAGS-to-link-tests.patch \
@@ -17,7 +18,11 @@  SRC_URI = "https://zlib.net/${BP}.tar.xz \
            "
 UPSTREAM_CHECK_URI = "http://zlib.net/"
 
-SRC_URI[sha256sum] = "7db46b8d7726232a621befaab4a1c870f00a90805511c0e0090441dac57def18"
+SRC_URI[sha256sum] = "91844808532e5ce316b3c010929493c0244f3d37593afd6de04f71821d5136d9"
+
+# When a new release is made the previous release is moved to fossils/, so add this
+# to PREMIRRORS so it is also searched automatically.
+PREMIRRORS:append = " https://zlib.net/ https://zlib.net/fossils/"
 
 CFLAGS += "-D_REENTRANT"