diff mbox series

[meta-oe] crucible: Add recipe

Message ID 20221016004555.3163258-1-festevam@gmail.com
State Under Review
Headers show
Series [meta-oe] crucible: Add recipe | expand

Commit Message

Fabio Estevam Oct. 16, 2022, 12:45 a.m. UTC
From: Fabio Estevam <festevam@denx.de>

crucible is an utility that provides userspace support for
reading and writing to the i.MX fuses.

Signed-off-by: Fabio Estevam <festevam@denx.de>
---
 .../crucible/crucible_2022.05.25.bb           | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-oe/recipes-support/crucible/crucible_2022.05.25.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/crucible/crucible_2022.05.25.bb b/meta-oe/recipes-support/crucible/crucible_2022.05.25.bb
new file mode 100644
index 000000000000..73856d5704b0
--- /dev/null
+++ b/meta-oe/recipes-support/crucible/crucible_2022.05.25.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "Utility that provides userspace support for reading and writing to the i.MX fuses"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=a64ced9463b8c81d08335d41966e0592"
+
+GO_IMPORT = "github.com/usbarmory/crucible"
+SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master"
+
+GO_INSTALL = "\
+    ${GO_IMPORT}/cmd/crucible \
+    ${GO_IMPORT}/cmd/habtool \
+"
+SRCREV = "837bdb65a20de240f92ea57727385352e06b977e"
+
+# Workaround for network access issue during compile step.
+# This needs to be fixed in the recipes buildsystem so that
+# it can be accomplished during do_fetch task.
+do_compile[network] = "1"
+
+inherit go-mod