diff mbox series

[meta-oe] freeglut: upgrade 3.2.1 -> 3.4.0

Message ID 1665215534-23236-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-oe] freeglut: upgrade 3.2.1 -> 3.4.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Oct. 8, 2022, 7:52 a.m. UTC
Changelog:
=========
Add GLUT_ACTIVE_SUPER modifier, and corresponding GLUT_KEY_SUPER_L and GLUT_KEY_SUPER_R special keys.
Fix RGB mode (GLUT_RGBA) colors on 8bpp displays on windows (construct default RGB332 palette).
Fix indexed color context creation on X11 and windows (GLUT_INDEX).
Add missing colormap management functions for X11 and windows (glutSetColor, glutGetColor).
Fix crash when calling glutTimerFuncUcall.
Fix FreeBSD build by essentially disabling the joystick code for newer FreeBSD versions.
Add fallbacks for the old GLX (<1.3) context creation API (glXChooseVisual/glXCreateContext)
Add fallbacks for OpenGL 1.0 (no vertex arrays/client state).
Use nanosleep instead of usleep on UNIX, which is more widely supported on old UNIX systems.
Fix build on X11 if GL_SAMPLES is not defined.
Fix overly strict context version checking on Android leading to context creation failure in some cases.
Fix GLUT_CURSOR_INFO on windows, should be IDC_HAND, not IDC_HELP.
Fix mismatched font declarations on X11.
Add alternative simple ways to build freeglut with native tools only, without having to use cmake.
Fix build on windows with cmake 3.0.0. Explicitly link with gdi32.
Fix build on MSVC 2005.
Fix build on MacOS X. Link with all the necessary X libraries.
Fix build on SGI IRIX.
Fix build on Android (mismatched function prototypes and missing glutCreateMenuUcall).
Add support for the ninja multi-config generator.
Removed spurious dependency on a C++ compiler. One of the demos was being compiled as C++ for no reason.
Silence unnecessary warnings when VBOs or GLSL are not available.
New demo programs: 3dview, keyboard, joystick.
Documentation: added MacOS X build instructions.
Made it possible to eventually support building freeglut as a single compilation unit
Other minor fixes.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../freeglut/{freeglut_3.2.1.bb => freeglut_3.4.0.bb}          | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
 rename meta-oe/recipes-graphics/freeglut/{freeglut_3.2.1.bb => freeglut_3.4.0.bb} (81%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb b/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
similarity index 81%
rename from meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
rename to meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
index 6ef9f74c70..627ce23544 100644
--- a/meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb
+++ b/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
@@ -4,8 +4,7 @@  LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=89c0b58a3e01ce3d8254c9f59e78adfb"
 
 SRC_URI = "https://sourceforge.net/projects/${BPN}/files/${BPN}/${PV}/${BPN}-${PV}.tar.gz"
-SRC_URI[md5sum] = "cd5c670c1086358598a6d4a9d166949d"
-SRC_URI[sha256sum] = "d4000e02102acaf259998c870e25214739d1f16f67f99cb35e4f46841399da68"
+SRC_URI[sha256sum] = "3c0bcb915d9b180a97edaebd011b7a1de54583a838644dcd42bb0ea0c6f3eaec"
 
 inherit cmake features_check