diff mbox series

[meta-arago,master/kirkstone,6/7] ti-tisdk: Remove uio-module-drv kernel module

Message ID 20221006150628.17044-6-afd@ti.com
State Superseded, archived
Delegated to: Denys Dmytriyenko
Headers show
Series [meta-arago,master/kirkstone,1/7] ti-crypto-examples: Remove ti-crypto-examples | expand

Commit Message

Andrew Davis Oct. 6, 2022, 3:06 p.m. UTC
UIO drivers are generally frowned upon and were only used here for some
K2 devices and PRUs before RPMSG. With these uses finally gone, lets
remove this out-of-tree module.

Signed-off-by: Andrew Davis <afd@ti.com>
---
 .../conf/distro/include/arago-source-ipk.inc  |  3 --
 ...ackagegroup-arago-tisdk-addons-sdk-host.bb |  9 ------
 .../packagegroup-arago-tisdk-addons.bb        | 20 -------------
 .../ti-tisdk-makefile/Makefile_uio-module-drv | 28 -------------------
 .../ti-tisdk-makefile_1.0.bb                  |  4 ---
 5 files changed, 64 deletions(-)
 delete mode 100644 meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_uio-module-drv
diff mbox series

Patch

diff --git a/meta-arago-distro/conf/distro/include/arago-source-ipk.inc b/meta-arago-distro/conf/distro/include/arago-source-ipk.inc
index a709fd00..5e5aad48 100644
--- a/meta-arago-distro/conf/distro/include/arago-source-ipk.inc
+++ b/meta-arago-distro/conf/distro/include/arago-source-ipk.inc
@@ -334,9 +334,6 @@  SRCIPK_INSTALL_DIR:pn-boot-monitor ?= "board-support/${PN}-${PV}"
 CREATE_SRCIPK:pn-hplib-mod ?= "1"
 SRCIPK_INSTALL_DIR:pn-hplib-mod ?= "board-support/extra-drivers/${PN}-${PV}"
 
-CREATE_SRCIPK:pn-uio-module-drv ?= "1"
-SRCIPK_INSTALL_DIR:pn-uio-module-drv ?= "board-support/extra-drivers/${PN}-${PV}"
-
 CREATE_SRCIPK:pn-pru-icss ?= "1"
 SRCIPK_INSTALL_DIR:pn-pru-icss ?= "example-applications/${PN}-${PV}"
 
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb
index 1814137b..9efc2cae 100644
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb
@@ -50,7 +50,6 @@  UTILS:append:am64xx = " \
 EXTRA_LIBS = ""
 
 EXTRA_LIBS:append:omap-a15 = " \
-    uio-module-drv-source \
     big-data-ipc-demo-source \
 "
 
@@ -59,14 +58,6 @@  EXTRA_LIBS:append:omap-a15 = " \
 #    gdbserverproxy-module-drv-source \
 #"
 
-EXTRA_LIBS:append:ti33x = " \
-    uio-module-drv-source \
-"
-
-EXTRA_LIBS:append:ti43x = " \
-    uio-module-drv-source \
-"
-
 PDM_ANOMALY_PKG_SRC = "\
     ${@bb.utils.contains('MACHINE_FEATURES', 'gpu', 'pdm-anomaly-detection-source', '', d)} \
 "
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
index f8c07164..f4e72a89 100644
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
@@ -34,16 +34,12 @@  UTILS_DSP = " \
 UTILS:append:ti33x = " mmc-utils \
                        switch-config \
                        pru-icss \
-                       uio-module-drv-test \
-                       uio-test-pruss \
 "
 
 UTILS:append:ti43x = " mmc-utils \
                        switch-config \
                        libdrm-omap \
                        pru-icss \
-                       uio-module-drv-test \
-                       uio-test-pruss \
 "
 
 UTILS:append:omap-a15 = " mmc-utils \
@@ -51,8 +47,6 @@  UTILS:append:omap-a15 = " mmc-utils \
                           libdrm-omap \
                           pru-icss \
                           ti-ipc-rtos-fw \
-                          uio-test-pruss \
-                          uio-module-drv-test \
 "
 
 UTILS:append:k3 = " mmc-utils \
@@ -78,19 +72,6 @@  UTILS:append:dra7xx = " \
                         ${@bb.utils.contains('MACHINE_FEATURES','gpu','glsdk-example-apps','',d)} \
 "
 
-EXTRA_LIBS = ""
-EXTRA_LIBS:append:omap-a15 = " \
-    uio-module-drv \
-"
-
-EXTRA_LIBS:append:ti43x = " \
-    uio-module-drv \
-"
-
-EXTRA_LIBS:append:ti33x = " \
-    uio-module-drv \
-"
-
 EXTRA_PACKAGES = " \
     nodejs \
     nodejs-npm \
@@ -118,7 +99,6 @@  EXTRA_PACKAGES:append:omap-a15 = " \
 RDEPENDS:${PN} = "\
     ${UTILS} \
     ${UTILS_UBOOT_FW} \
-    ${EXTRA_LIBS} \
 "
 
 RDEPENDS:${PN}-extra = "\
diff --git a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_uio-module-drv b/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_uio-module-drv
deleted file mode 100644
index 544e0eb8..00000000
--- a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_uio-module-drv
+++ /dev/null
@@ -1,28 +0,0 @@ 
-uio-module-drv: linux
-	@echo ================================
-	@echo      Building uio-module-drv
-	@echo ================================
-	@cd board-support/extra-drivers; \
-	cd `find . -maxdepth 1 -type d -name "uio-module-drv*"`; \
-	make ARCH=__KERNEL_ARCH__ KERNEL_SRC=$(LINUXKERNEL_INSTALL_DIR)
-
-uio-module-drv_clean:
-	@echo ================================
-	@echo      Cleaning uio-module-drv
-	@echo ================================
-	@cd board-support/extra-drivers; \
-	cd `find . -maxdepth 1 -type d -name "uio-module-drv*"`; \
-	make ARCH=__KERNEL_ARCH__ KERNEL_SRC=$(LINUXKERNEL_INSTALL_DIR) clean
-
-uio-module-drv_install:
-	@echo ================================
-	@echo      Installing uio-module-drv
-	@echo ================================
-	@if [ ! -d $(DESTDIR) ] ; then \
-		echo "The extracted target filesystem directory doesn't exist."; \
-		echo "Please run setup.sh in the SDK's root directory and then try again."; \
-		exit 1; \
-	fi
-	@cd board-support/extra-drivers; \
-	cd `find . -maxdepth 1 -type d -name "uio-module-drv*"`; \
-	make ARCH=__KERNEL_ARCH__  KERNEL_SRC=$(LINUXKERNEL_INSTALL_DIR)  INSTALL_MOD_PATH=$(DESTDIR) PREFIX=$(SDK_PATH_TARGET) INSTALL_MOD_STRIP=$(INSTALL_MOD_STRIP) modules_install
diff --git a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb b/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb
index c4d8c408..68d0f458 100644
--- a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb
+++ b/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb
@@ -36,7 +36,6 @@  SRC_URI = "\
     file://Makefile_opencl-examples \
     file://Makefile_boot-monitor \
     file://Makefile_hplib-mod \
-    file://Makefile_uio-module-drv \
     file://Makefile_pru-icss \
     file://Makefile_qt-opencv-opencl-opengl-multithreaded \
     file://Makefile_openmpacc-examples \
@@ -77,7 +76,6 @@  MAKEFILES:append:ti33x = " u-boot-spl \
                            cryptodev \
                            ti-sgx-ddk-km \
                            pru-icss \
-                           uio-module-drv \
 			   mmwavegesture-hmi \
                            pdm-anomaly-detection \
 "
@@ -88,7 +86,6 @@  MAKEFILES:append:ti43x = " u-boot-spl \
                            image-gallery \
                            ti-sgx-ddk-km \
                            pru-icss \
-                           uio-module-drv \
 			   mmwavegesture-hmi \
                            pdm-anomaly-detection \
 "
@@ -110,7 +107,6 @@  MAKEFILES:append:omap-a15 = " u-boot-spl \
                               pru-icss \
                               ti-gc320-driver \
                               barcode-roi \
-                              uio-module-drv \
 			      mmwavegesture-hmi \
                               pdm-anomaly-detection \
                               ti-ipc \