diff mbox series

[1/3] arm-bsp/trusted-firmware-m: Make branch names configurable

Message ID 20221003112959.2123869-1-peter.hoyes@arm.com
State New
Headers show
Series [1/3] arm-bsp/trusted-firmware-m: Make branch names configurable | expand

Commit Message

Peter Hoyes Oct. 3, 2022, 11:29 a.m. UTC
From: Peter Hoyes <Peter.Hoyes@arm.com>

In order to support overriding the branch names in other layers, extract
the branch name for each repository and set using default assignment.

Issue-Id: SCM-4964
Signed-off-by: Peter Hoyes <Peter.Hoyes@arm.com>
Change-Id: I09d0c1f1d012c1abb84648ad974883bbdaa1db7a
---
 .../trusted-firmware-m/trusted-firmware-m_1.6.0.bb    | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

Comments

Jon Mason Oct. 3, 2022, 4:37 p.m. UTC | #1
On Mon, 3 Oct 2022 12:29:57 +0100, Peter Hoyes wrote:
> In order to support overriding the branch names in other layers, extract
> the branch name for each repository and set using default assignment.

Applied, thanks!

[1/3] arm-bsp/trusted-firmware-m: Make branch names configurable
      commit: ff4a322c838f5c12caf78597dbd2ab777195b0f6
[2/3] arm/classes: Migrate TF-M image signing to bbclass
      commit: 97c7e9f08e6643884cf078a60cf54a8243fbe5cf
[3/3] arm-bsp/corstone1000: Refactor image signing to use new bbclass
      commit: fc26f65b1ca2680293a120a1660a4f226e8e4d16

Best regards,
diff mbox series

Patch

diff --git a/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.6.0.bb b/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.6.0.bb
index bda27713..c10efd5a 100644
--- a/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.6.0.bb
+++ b/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.6.0.bb
@@ -16,20 +16,23 @@  LIC_FILES_CHKSUM = "file://license.rst;md5=07f368487da347f3c7bd0fc3085f3afa \
                     file://../mcuboot/LICENSE;md5=b6ee33f1d12a5e6ee3de1e82fb51eeb8"
 
 SRC_URI  = "git://git.trustedfirmware.org/TF-M/trusted-firmware-m.git;protocol=https;branch=${SRCBRANCH_tfm};name=tfm;destsuffix=git/tfm \
-            git://git.trustedfirmware.org/TF-M/tf-m-tests.git;protocol=https;branch=release/1.6.x;name=tfm-tests;destsuffix=git/tf-m-tests \
-            git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=master;name=mbedtls;destsuffix=git/mbedtls \
-            git://github.com/mcu-tools/mcuboot.git;protocol=https;branch=main;name=mcuboot;destsuffix=git/mcuboot \
+            git://git.trustedfirmware.org/TF-M/tf-m-tests.git;protocol=https;branch=${SRCBRANCH_tfm-tests};name=tfm-tests;destsuffix=git/tf-m-tests \
+            git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=${SRCBRANCH_mbedtls};name=mbedtls;destsuffix=git/mbedtls \
+            git://github.com/mcu-tools/mcuboot.git;protocol=https;branch=${SRCBRANCH_mcuboot};name=mcuboot;destsuffix=git/mcuboot \
             "
 
 # The required dependencies are documented in tf-m/config/config_default.cmake
 # TF-Mv1.6.0
-SRCBRANCH_tfm = "release/1.6.x"
+SRCBRANCH_tfm ?= "release/1.6.x"
 SRCREV_tfm = "7387d88158701a3c51ad51c90a05326ee12847a8"
 # mbedtls-3.1.0
+SRCBRANCH_mbedtls ?= "master"
 SRCREV_mbedtls = "d65aeb37349ad1a50e0f6c9b694d4b5290d60e49"
 # TF-Mv1.6.0
+SRCBRANCH_tfm-tests ?= "release/1.6.x"
 SRCREV_tfm-tests = "723905d46019596f3f2df66d79b5d6bff6f3f213"
 # v1.9.0
+SRCBRANCH_mcuboot ?= "main"
 SRCREV_mcuboot = "c657cbea75f2bb1faf1fceacf972a0537a8d26dd"
 
 UPSTREAM_CHECK_GITTAGREGEX = "^TF-Mv(?P<pver>\d+(\.\d+)+)$"