diff mbox series

openssl: Add missing perl module runtime dependencies for ptests

Message ID 20220930041614.2704304-1-raj.khem@gmail.com
State New
Headers show
Series openssl: Add missing perl module runtime dependencies for ptests | expand

Commit Message

Khem Raj Sept. 30, 2022, 4:16 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-connectivity/openssl/openssl_3.0.5.bb | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comments

Ross Burton Sept. 30, 2022, 10:16 a.m. UTC | #1
On 30 Sep 2022, at 05:16, Khem Raj via lists.openembedded.org <raj.khem=gmail.com@lists.openembedded.org> wrote:
> -RDEPENDS:${PN}-ptest += "openssl-bin perl perl-modules bash sed"
> +RDEPENDS:${PN}-ptest += "bash sed openssl-bin \
> +                         perl perl-modules \

I thought the point of perl-modules was to depend on the entire standard library, so isn’t this a bug in perl-modules?

Ross
Ross Burton Sept. 30, 2022, 10:37 a.m. UTC | #2
> On 30 Sep 2022, at 11:16, Ross Burton via lists.openembedded.org <ross.burton=arm.com@lists.openembedded.org> wrote:
> 
> On 30 Sep 2022, at 05:16, Khem Raj via lists.openembedded.org <raj.khem=gmail.com@lists.openembedded.org> wrote:
>> -RDEPENDS:${PN}-ptest += "openssl-bin perl perl-modules bash sed"
>> +RDEPENDS:${PN}-ptest += "bash sed openssl-bin \
>> +                         perl perl-modules \
> 
> I thought the point of perl-modules was to depend on the entire standard library, so isn’t this a bug in perl-modules?

My perl-modules RRECOMMENDS on, eg, perl-module-tap-parser.

Are you building an image with recommendations turned off?

Ross
Khem Raj Sept. 30, 2022, 4:03 p.m. UTC | #3
On Fri, Sep 30, 2022 at 3:37 AM Ross Burton <Ross.Burton@arm.com> wrote:

>
>
> > On 30 Sep 2022, at 11:16, Ross Burton via lists.openembedded.org
> <ross.burton=arm.com@lists.openembedded.org> wrote:
> >
> > On 30 Sep 2022, at 05:16, Khem Raj via lists.openembedded.org <raj.khem=
> gmail.com@lists.openembedded.org> wrote:
> >> -RDEPENDS:${PN}-ptest += "openssl-bin perl perl-modules bash sed"
> >> +RDEPENDS:${PN}-ptest += "bash sed openssl-bin \
> >> +                         perl perl-modules \
> >
> > I thought the point of perl-modules was to depend on the entire standard
> library, so isn’t this a bug in perl-modules?
>
> My perl-modules RRECOMMENDS on, eg, perl-module-tap-parser.
>
> Are you building an image with recommendations turned off?


Good point I will check in think it worked fine with glibc but not with
musl based images I see that Perl-modules is fully empty in packages-split
area so soMething does not add up

>
>
> Ross
Ross Burton Sept. 30, 2022, 4:29 p.m. UTC | #4
> On 30 Sep 2022, at 17:03, Khem Raj via lists.openembedded.org <raj.khem=gmail.com@lists.openembedded.org> wrote:
> 
> Good point I will check in think it worked fine with glibc but not with musl based images I see that Perl-modules is fully empty in packages-split area so soMething does not add up 

It will be empty as it’s a metapackage, but it should have lots of rrecommends.

Ross
Khem Raj Sept. 30, 2022, 4:42 p.m. UTC | #5
On Fri, Sep 30, 2022 at 9:30 AM Ross Burton <Ross.Burton@arm.com> wrote:

>
>
> > On 30 Sep 2022, at 17:03, Khem Raj via lists.openembedded.org <raj.khem=
> gmail.com@lists.openembedded.org> wrote:
> >
> > Good point I will check in think it worked fine with glibc but not with
> musl based images I see that Perl-modules is fully empty in packages-split
> area so soMething does not add up
>
> It will be empty as it’s a metapackage, but it should have lots of
> rrecommends.


Right that was the point the folder should not have been empty it should
have had those rdepends control files


>
> Ross
Ross Burton Sept. 30, 2022, 5:01 p.m. UTC | #6
> On 30 Sep 2022, at 17:42, Khem Raj <raj.khem@gmail.com> wrote:
> > Good point I will check in think it worked fine with glibc but not with musl based images I see that Perl-modules is fully empty in packages-split area so soMething does not add up 
> 
> It will be empty as it’s a metapackage, but it should have lots of rrecommends.
> 
> Right that was the point the folder should not have been empty it should have had those rdepends control files 


My perl-modules pkgdata built with musl:

RRECOMMENDS:perl-modules: perl-module-cpan perl-module-unicore perl-module-b perl-module-compress-raw-bzip2 perl-module-compress-raw-zlib perl-module-cwd perl-module-data-dumper perl-module-devel-peek perl-module-digest-md5 perl-module-digest-sha perl-module-encode-byte perl-module-encode-cn […]

Can you retest?  Unless you’re running in a no-recommends build I can’t see how this can be.

Arguably, perl-modules should depends on the packages, otherwise it totally breaks in no-recommends environments.  If you install perl-modules you want the entire library, not just a fraction of it.

Ross
Khem Raj Sept. 30, 2022, 5:08 p.m. UTC | #7
On Fri, Sep 30, 2022 at 10:01 AM Ross Burton <Ross.Burton@arm.com> wrote:
>
>
> > On 30 Sep 2022, at 17:42, Khem Raj <raj.khem@gmail.com> wrote:
> > > Good point I will check in think it worked fine with glibc but not with musl based images I see that Perl-modules is fully empty in packages-split area so soMething does not add up
> >
> > It will be empty as it’s a metapackage, but it should have lots of rrecommends.
> >
> > Right that was the point the folder should not have been empty it should have had those rdepends control files
>
>
> My perl-modules pkgdata built with musl:
>
> RRECOMMENDS:perl-modules: perl-module-cpan perl-module-unicore perl-module-b perl-module-compress-raw-bzip2 perl-module-compress-raw-zlib perl-module-cwd perl-module-data-dumper perl-module-devel-peek perl-module-digest-md5 perl-module-digest-sha perl-module-encode-byte perl-module-encode-cn […]
>
> Can you retest?  Unless you’re running in a no-recommends build I can’t see how this can be.
>
> Arguably, perl-modules should depends on the packages, otherwise it totally breaks in no-recommends environments.  If you install perl-modules you want the entire library, not just a fraction of it.

are you building with opkg ?

>
> Ross
Khem Raj Sept. 30, 2022, 5:10 p.m. UTC | #8
On Fri, Sep 30, 2022 at 10:08 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Fri, Sep 30, 2022 at 10:01 AM Ross Burton <Ross.Burton@arm.com> wrote:
> >
> >
> > > On 30 Sep 2022, at 17:42, Khem Raj <raj.khem@gmail.com> wrote:
> > > > Good point I will check in think it worked fine with glibc but not with musl based images I see that Perl-modules is fully empty in packages-split area so soMething does not add up
> > >
> > > It will be empty as it’s a metapackage, but it should have lots of rrecommends.
> > >
> > > Right that was the point the folder should not have been empty it should have had those rdepends control files
> >
> >
> > My perl-modules pkgdata built with musl:
> >
> > RRECOMMENDS:perl-modules: perl-module-cpan perl-module-unicore perl-module-b perl-module-compress-raw-bzip2 perl-module-compress-raw-zlib perl-module-cwd perl-module-data-dumper perl-module-devel-peek perl-module-digest-md5 perl-module-digest-sha perl-module-encode-byte perl-module-encode-cn […]
> >
> > Can you retest?  Unless you’re running in a no-recommends build I can’t see how this can be.
> >
> > Arguably, perl-modules should depends on the packages, otherwise it totally breaks in no-recommends environments.  If you install perl-modules you want the entire library, not just a fraction of it.
>
> are you building with opkg ?

and here is my list of bad recommendations

BAD_RECOMMENDATIONS += "eudev-hwdb udev-hwdb libmodule-build-perl"

>
> >
> > Ross
Khem Raj Sept. 30, 2022, 5:46 p.m. UTC | #9
On Fri, Sep 30, 2022 at 10:10 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Fri, Sep 30, 2022 at 10:08 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > On Fri, Sep 30, 2022 at 10:01 AM Ross Burton <Ross.Burton@arm.com> wrote:
> > >
> > >
> > > > On 30 Sep 2022, at 17:42, Khem Raj <raj.khem@gmail.com> wrote:
> > > > > Good point I will check in think it worked fine with glibc but not with musl based images I see that Perl-modules is fully empty in packages-split area so soMething does not add up
> > > >
> > > > It will be empty as it’s a metapackage, but it should have lots of rrecommends.
> > > >
> > > > Right that was the point the folder should not have been empty it should have had those rdepends control files
> > >
> > >
> > > My perl-modules pkgdata built with musl:
> > >
> > > RRECOMMENDS:perl-modules: perl-module-cpan perl-module-unicore perl-module-b perl-module-compress-raw-bzip2 perl-module-compress-raw-zlib perl-module-cwd perl-module-data-dumper perl-module-devel-peek perl-module-digest-md5 perl-module-digest-sha perl-module-encode-byte perl-module-encode-cn […]
> > >
> > > Can you retest?  Unless you’re running in a no-recommends build I can’t see how this can be.
> > >
> > > Arguably, perl-modules should depends on the packages, otherwise it totally breaks in no-recommends environments.  If you install perl-modules you want the entire library, not just a fraction of it.
> >
> > are you building with opkg ?
>
> and here is my list of bad recommendations
>
> BAD_RECOMMENDATIONS += "eudev-hwdb udev-hwdb libmodule-build-perl"
>

OK my RRECOMMENDS:perl-modules are fine similar to Ross, however they
does not get pulled into final image when openssl-ptest is added to
IMAGE_INSTALL

> >
> > >
> > > Ross
Alexandre Belloni Sept. 30, 2022, 8:44 p.m. UTC | #10
Hello,

This caused many issues on the autobuilders, similar to those:

https://autobuilder.yoctoproject.org/typhoon/#/builders/65/builds/5982/steps/11/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/96/builds/3796/steps/11/logs/stdio

On 29/09/2022 21:16:14-0700, Khem Raj wrote:
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-connectivity/openssl/openssl_3.0.5.bb | 11 ++++++++++-
>  1 file changed, 10 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-connectivity/openssl/openssl_3.0.5.bb b/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
> index 04aff04fab..119e58ed24 100644
> --- a/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
> +++ b/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
> @@ -243,7 +243,16 @@ CONFFILES:openssl-conf = "${sysconfdir}/ssl/openssl.cnf"
>  
>  RRECOMMENDS:libcrypto += "openssl-conf ${PN}-ossl-module-legacy"
>  RDEPENDS:${PN}-misc = "perl"
> -RDEPENDS:${PN}-ptest += "openssl-bin perl perl-modules bash sed"
> +RDEPENDS:${PN}-ptest += "bash sed openssl-bin \
> +                         perl perl-modules \
> +                         perl-module-file-spec-functions \
> +                         perl-module-findbin perl-module-harness perl-module-tap-base \
> +                         perl-module-tap-object perl-module-tap-parser-sourcehandler-executable \
> +                         perl-module-tap-formatter-file perl-module-tap-formatter-session \
> +                         perl-module-tap-formatter-base perl-module-tap-parser \
> +                         perl-module-tap-parser-scheduler perl-module-test-more \
> +                         perl-module-pod-text perl-module-encode-encoding \
> +                         "
>  
>  RDEPENDS:${PN}-bin += "openssl-conf"
>  
> -- 
> 2.37.3
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#171204): https://lists.openembedded.org/g/openembedded-core/message/171204
> Mute This Topic: https://lists.openembedded.org/mt/94010252/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Sept. 30, 2022, 10:11 p.m. UTC | #11
Thanks Alex, I will rework it.

On Fri, Sep 30, 2022 at 1:44 PM Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> Hello,
>
> This caused many issues on the autobuilders, similar to those:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/65/builds/5982/steps/11/logs/stdio
> https://autobuilder.yoctoproject.org/typhoon/#/builders/96/builds/3796/steps/11/logs/stdio
>
> On 29/09/2022 21:16:14-0700, Khem Raj wrote:
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >  meta/recipes-connectivity/openssl/openssl_3.0.5.bb | 11 ++++++++++-
> >  1 file changed, 10 insertions(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-connectivity/openssl/openssl_3.0.5.bb b/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
> > index 04aff04fab..119e58ed24 100644
> > --- a/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
> > +++ b/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
> > @@ -243,7 +243,16 @@ CONFFILES:openssl-conf = "${sysconfdir}/ssl/openssl.cnf"
> >
> >  RRECOMMENDS:libcrypto += "openssl-conf ${PN}-ossl-module-legacy"
> >  RDEPENDS:${PN}-misc = "perl"
> > -RDEPENDS:${PN}-ptest += "openssl-bin perl perl-modules bash sed"
> > +RDEPENDS:${PN}-ptest += "bash sed openssl-bin \
> > +                         perl perl-modules \
> > +                         perl-module-file-spec-functions \
> > +                         perl-module-findbin perl-module-harness perl-module-tap-base \
> > +                         perl-module-tap-object perl-module-tap-parser-sourcehandler-executable \
> > +                         perl-module-tap-formatter-file perl-module-tap-formatter-session \
> > +                         perl-module-tap-formatter-base perl-module-tap-parser \
> > +                         perl-module-tap-parser-scheduler perl-module-test-more \
> > +                         perl-module-pod-text perl-module-encode-encoding \
> > +                         "
> >
> >  RDEPENDS:${PN}-bin += "openssl-conf"
> >
> > --
> > 2.37.3
> >
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#171204): https://lists.openembedded.org/g/openembedded-core/message/171204
> > Mute This Topic: https://lists.openembedded.org/mt/94010252/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Ross Burton Oct. 1, 2022, 8:01 p.m. UTC | #12
> OK my RRECOMMENDS:perl-modules are fine similar to Ross, however they
> does not get pulled into final image when openssl-ptest is added to
> IMAGE_INSTALL


That’s definitely worth looking into. This isn’t the solution, assuming you’re not disabling recommendations in your image recipe.

Ross
Khem Raj Oct. 1, 2022, 10:29 p.m. UTC | #13
On Sat, Oct 1, 2022 at 1:01 PM Ross Burton <ross.burton@arm.com> wrote:

> > OK my RRECOMMENDS:perl-modules are fine similar to Ross, however they
> > does not get pulled into final image when openssl-ptest is added to
> > IMAGE_INSTALL
>
>
> That’s definitely worth looking into. This isn’t the solution, assuming
> you’re not disabling recommendations in your image recipe.


Core-image-ptest works so hmm I don’t know what’s wrong with my image


>
> Ross
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#171349):
> https://lists.openembedded.org/g/openembedded-core/message/171349
> Mute This Topic: https://lists.openembedded.org/mt/94010252/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Oct. 4, 2022, 6:43 a.m. UTC | #14
On Sat, Oct 1, 2022 at 3:29 PM Khem Raj <raj.khem@gmail.com> wrote:
>
>
>
> On Sat, Oct 1, 2022 at 1:01 PM Ross Burton <ross.burton@arm.com> wrote:
>>
>> > OK my RRECOMMENDS:perl-modules are fine similar to Ross, however they
>> > does not get pulled into final image when openssl-ptest is added to
>> > IMAGE_INSTALL
>>
>>
>> That’s definitely worth looking into. This isn’t the solution, assuming you’re not disabling recommendations in your image recipe.
>
>
> Core-image-ptest works so hmm I don’t know what’s wrong with my image
>

I think the issue seems with any image using opkg backend and adding

IMAGE_FEATURES += "ptest-pkgs"

in local.conf

DISTRO_FEATURES += "ptest"

It does not even bring ptest-runner which is in RRECOMMENDS of every
ptest package.

The core-image-ptest work perhaps because they explicitly specify
certain ptest packages and they bring in the needed deps


>>
>>
>> Ross
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#171349): https://lists.openembedded.org/g/openembedded-core/message/171349
>> Mute This Topic: https://lists.openembedded.org/mt/94010252/1997914
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/openssl/openssl_3.0.5.bb b/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
index 04aff04fab..119e58ed24 100644
--- a/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
+++ b/meta/recipes-connectivity/openssl/openssl_3.0.5.bb
@@ -243,7 +243,16 @@  CONFFILES:openssl-conf = "${sysconfdir}/ssl/openssl.cnf"
 
 RRECOMMENDS:libcrypto += "openssl-conf ${PN}-ossl-module-legacy"
 RDEPENDS:${PN}-misc = "perl"
-RDEPENDS:${PN}-ptest += "openssl-bin perl perl-modules bash sed"
+RDEPENDS:${PN}-ptest += "bash sed openssl-bin \
+                         perl perl-modules \
+                         perl-module-file-spec-functions \
+                         perl-module-findbin perl-module-harness perl-module-tap-base \
+                         perl-module-tap-object perl-module-tap-parser-sourcehandler-executable \
+                         perl-module-tap-formatter-file perl-module-tap-formatter-session \
+                         perl-module-tap-formatter-base perl-module-tap-parser \
+                         perl-module-tap-parser-scheduler perl-module-test-more \
+                         perl-module-pod-text perl-module-encode-encoding \
+                         "
 
 RDEPENDS:${PN}-bin += "openssl-conf"