diff mbox series

[master/kirkstone] websocketd: enable network access for compile task

Message ID 20220920192616.13717-1-denis@denix.org
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series [master/kirkstone] websocketd: enable network access for compile task | expand

Commit Message

Denys Dmytriyenko Sept. 20, 2022, 7:26 p.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

Since go modules do own fetching during compile time.

Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 .../recipes-devtools/websocketd/websocketd_0.4.1.bb             | 2 ++
 1 file changed, 2 insertions(+)

Comments

Ryan Eatmon Sept. 23, 2022, 5:26 p.m. UTC | #1
On 9/20/2022 14:26, Denys Dmytriyenko wrote:
> From: Denys Dmytriyenko <denys@konsulko.com>
> 
> Since go modules do own fetching during compile time.
> 
> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
> ---
>   .../recipes-devtools/websocketd/websocketd_0.4.1.bb             | 2 ++
>   1 file changed, 2 insertions(+)
> 
> diff --git a/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb b/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb
> index 2ec6a19a..2d90f8fe 100644
> --- a/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb
> +++ b/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb
> @@ -12,7 +12,9 @@ SRCREV = "035c18cc3e6962dabd5ea2ad8845260726a4a99e"
>   
>   # bitbake only exports proxy variables during fetching, but go handles
>   # module fetching on its own during compile and needs proxy settings
> +# along with network access for the task
>   export http_proxy


We also need "export https_proxy" in the recipe.  Do you want to submit 
a v2 so that we have both required changes in one commit?


> +do_compile[network] = "1"
>   
>   # Development package contains all the examples in different languages
>   INSANE_SKIP:${PN}-dev = "file-rdeps"
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb b/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb
index 2ec6a19a..2d90f8fe 100644
--- a/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb
+++ b/meta-arago-extras/recipes-devtools/websocketd/websocketd_0.4.1.bb
@@ -12,7 +12,9 @@  SRCREV = "035c18cc3e6962dabd5ea2ad8845260726a4a99e"
 
 # bitbake only exports proxy variables during fetching, but go handles
 # module fetching on its own during compile and needs proxy settings
+# along with network access for the task
 export http_proxy
+do_compile[network] = "1"
 
 # Development package contains all the examples in different languages
 INSANE_SKIP:${PN}-dev = "file-rdeps"