[meta-python] python3-pyephem: upgrade 4.1 -> 4.1.1

Message ID 1638436315-9778-1-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-pyephem: upgrade 4.1 -> 4.1.1 | expand

Commit Message

XU Huan Dec. 2, 2021, 9:11 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

changelog:
===============================================================
When you provide PyEphem with a Python datetime that has a time
 zone attached, PyEphem now detects the time zone and converts
the date and time to UTC automatically.

A new search routine had been written and tested to power the
:ref:`transit-rising-setting` methods previous_rising(),
previous_setting(), next_rising(), and next_setting(). They
should no longer be susceptible to getting hung up in a loop.
You should also find them substantially faster.

Fixed the constellation() routine so that it uses astrometric,
rather than apparent, right ascension and declination. This
should make it more accurate along the borders of each
constellation.

Fixed how the underlying “libastro” library computes whether a
body’s image is deflected by gravity when its light passes close
 to the Sun. Previously, users would see coordinates jump
unexpectedly as the deflection formula turned on and off haphazardly.

Fixed the star positions in the ephem.stars star catalog by adding
 8.75 years of proper motion to each star. Previously, each
1991.25 position from the Hipparcos catalog was being incorrectly
treated as a 2000.0 position.

A new routine unrefract() lets you compute the real altitude of
a body that you observe in the sky at a given apparent altitude.

The old cities.lookup() function is now officially deprecated.
Because of a Google API restriction, it stopped working in 2018.

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../{python3-pyephem_4.1.bb => python3-pyephem_4.1.1.bb}        | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-extended/python-pyephem/{python3-pyephem_4.1.bb => python3-pyephem_4.1.1.bb} (77%)

Patch

diff --git a/meta-python/recipes-extended/python-pyephem/python3-pyephem_4.1.bb b/meta-python/recipes-extended/python-pyephem/python3-pyephem_4.1.1.bb
similarity index 77%
rename from meta-python/recipes-extended/python-pyephem/python3-pyephem_4.1.bb
rename to meta-python/recipes-extended/python-pyephem/python3-pyephem_4.1.1.bb
index add4458333..ec3cde87d3 100644
--- a/meta-python/recipes-extended/python-pyephem/python3-pyephem_4.1.bb
+++ b/meta-python/recipes-extended/python-pyephem/python3-pyephem_4.1.1.bb
@@ -4,7 +4,7 @@  HOMEPAGE = "http://rhodesmill.org/pyephem/"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=9c930b395b435b00bb13ec83b0c99f40"
 
-SRC_URI[sha256sum] = "c076794a511a34b5b91871c1cf6374dbc323ec69fca3f50eb718f20b171259d6"
+SRC_URI[sha256sum] = "dba9e05c78ce910ae75a06351a5592479191a8dc570ac0cd6d18a77e98138873"
 
 PYPI_PACKAGE = "ephem"