gcc: Dropping mips workaround

Message ID 20211115112308.3974991-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 567e199862acb948cb8b3361010a9ec221147c41
Headers show
Series gcc: Dropping mips workaround | expand

Commit Message

Richard Purdie Nov. 15, 2021, 11:23 a.m. UTC
I've tested without this and the ptest results for mips are the same with
and without it so the issue this was fixing in gcc 9 was likely resolved
by gcc 11.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/binutils/binutils_2.37.bb | 4 ----
 1 file changed, 4 deletions(-)

Comments

Khem Raj Nov. 15, 2021, 5:19 p.m. UTC | #1
lgtm

On 11/15/21 3:23 AM, Richard Purdie wrote:
> I've tested without this and the ptest results for mips are the same with
> and without it so the issue this was fixing in gcc 9 was likely resolved
> by gcc 11.
> 
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>   meta/recipes-devtools/binutils/binutils_2.37.bb | 4 ----
>   1 file changed, 4 deletions(-)
> 
> diff --git a/meta/recipes-devtools/binutils/binutils_2.37.bb b/meta/recipes-devtools/binutils/binutils_2.37.bb
> index 7430bf13425..12a6fb55776 100644
> --- a/meta/recipes-devtools/binutils/binutils_2.37.bb
> +++ b/meta/recipes-devtools/binutils/binutils_2.37.bb
> @@ -27,10 +27,6 @@ EXTRA_OECONF:class-native = "--enable-targets=all \
>   
>   PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'debuginfod', d)}"
>   PACKAGECONFIG[debuginfod] = "--with-debuginfod, --without-debuginfod, elfutils"
> -# gcc9.0 end up mis-compiling libbfd.so with O2 which then crashes on target
> -# So remove -O2 and use -Os as workaround
> -SELECTED_OPTIMIZATION:remove:mipsarch = "-O2"
> -SELECTED_OPTIMIZATION:append:mipsarch = " -Os"
>   
>   do_install:class-native () {
>   	autotools_do_install
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#158279): https://lists.openembedded.org/g/openembedded-core/message/158279
> Mute This Topic: https://lists.openembedded.org/mt/87066754/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-devtools/binutils/binutils_2.37.bb b/meta/recipes-devtools/binutils/binutils_2.37.bb
index 7430bf13425..12a6fb55776 100644
--- a/meta/recipes-devtools/binutils/binutils_2.37.bb
+++ b/meta/recipes-devtools/binutils/binutils_2.37.bb
@@ -27,10 +27,6 @@  EXTRA_OECONF:class-native = "--enable-targets=all \
 
 PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'debuginfod', d)}"
 PACKAGECONFIG[debuginfod] = "--with-debuginfod, --without-debuginfod, elfutils"
-# gcc9.0 end up mis-compiling libbfd.so with O2 which then crashes on target
-# So remove -O2 and use -Os as workaround
-SELECTED_OPTIMIZATION:remove:mipsarch = "-O2"
-SELECTED_OPTIMIZATION:append:mipsarch = " -Os"
 
 do_install:class-native () {
 	autotools_do_install